Opened 11 years ago

Closed 8 years ago

#4319 closed defect (worksforme)

ogr read dxf files problem

Reported by: liminlu0314 Owned by: warmerdam
Priority: normal Milestone:
Component: OGR_SF Version: 1.8.1
Severity: normal Keywords: ogr dxf
Cc:

Description

When I use the ogr library to read a dxf file, find and read out the shape of the drawing in AutoCAD is not the same. Dxf file using arcinfo to convert shp file, then use the ogr library read dxf file and shp file to compare the coordinates of the points, then the points read out of the dxf file is more than the points from shp file. http://hi.csdn.net/attachment/201111/1/1081231_1320155162393p.png Thank you for this work.

Attachments (1)

dxf file.rar (13.4 KB ) - added by liminlu0314 11 years ago.
this rar file has the dxf file and the shp file

Download all attachments as: .zip

Change History (2)

by liminlu0314, 11 years ago

Attachment: dxf file.rar added

this rar file has the dxf file and the shp file

comment:1 by Jukka Rahkonen, 8 years ago

Resolution: worksforme
Status: newclosed

Can't reproduce. Tested with GDAL 2.0-dev and QGIS 2.0.1 and both show nice curved shape.

Note: See TracTickets for help on using tickets.