Opened 11 years ago

Closed 4 years ago

#4197 closed defect (wontfix)

Generating overviews fail under specific conditions

Reported by: rprinceley Owned by: warmerdam
Priority: normal Milestone: closed_because_of_github_migration
Component: default Version: 1.8.1
Severity: normal Keywords:
Cc: gaopeng

Description

Under specific conditions - Windows 2008R2 x64 (32bit binaries) with a specific NAS, building pyramids fail for small images. This looks like a hardware / environment specific bug and is difficult to recreate.

I tracked down the root cause to OVR not being flushed to disk in between overviews when building pyramids.

Since GDALRegenerateOverviewsMultiBand does not actually flush data to disk (TIFFFlush):

- If the compressed overview is small enough to fit in OS / file cache, 
  it does not get flushed to disk automatically.
- Next TIFF directory offset is computed based on file size which has not 
  been updated yet (because file buffers haven't been flushed).

I've added calls to GDALDataset::FlushCache() to explicitly flush OVR to disk (r22936) in 1.8-esri branch.

Change History (2)

comment:1 by Jukka Rahkonen, 8 years ago

Would there be a reason to do the same than in r22936 also in non-esri branch?

comment:2 by Even Rouault, 4 years ago

Milestone: closed_because_of_github_migration
Resolution: wontfix
Status: newclosed

This ticket has been automatically closed because Trac is no longer used for GDAL bug tracking, since the project has migrated to GitHub. If you believe this ticket is still valid, you may file it to https://github.com/OSGeo/gdal/issues if it is not already reported there.

Note: See TracTickets for help on using tickets.