Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#3676 closed defect (fixed)

ECW SDK 4.x Update Required?

Reported by: warmerdam Owned by: warmerdam
Priority: normal Milestone:
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: ECW
Cc: chaitanya

Description

There are suggestions the existing GDAL trunk ECW driver code might not work with the ECW SDK 4.x series as it was developed for the 3.3 code base. This ticket is intended to address updating the driver to work with the latested SDK (4.1.x at this time). Note that the driver also needs to work smoothly with the 3.3 SDK which might be the last pseudo-open-source version.

Change History (6)

comment:1 Changed 9 years ago by rfleming

Hi,

Has it been confirmed that there is an issue using the 4.1 SDK? If so is there an estimated time frame for a fix?

Thanks

comment:2 Changed 9 years ago by warmerdam

Cc: chaitanya added
Owner: changed from chaitanya to warmerdam

I have dropped a line to Paul Beaty to check on the status of things. My understanding is that an Erdas staff member is working on updates to the GDAL ECW driver.

Also, reportedly the 4.1 SDK is now available without an interactive interview while the old SDK is no longer provided by Erdas. So the issue is becoming more pressing.

Since I have a client willing to pay for integration work, I'll take this ticket back.

comment:3 Changed 9 years ago by warmerdam

In trunk I have updated the code to work with the ECW SDK 4.1 read only sdk (r20918,r20917,r20916).

In my nmake.opt I declared:

ECW_PLUGIN = YES
ECWDIR  = 	C:\warmerda\ECWSDK-4.1Beta
ECWFLAGS =	-I$(ECWDIR)\include -DNO_COMPRESS -DECWSDK_VERSION=41
ECWLIB  = 	$(ECWDIR)\lib\vc90\win32\NCSEcw4_RO.lib \
		$(ECWDIR)\lib\vc90\win32\NCSUtil4.lib \
		$(ECWDIR)\lib\vc90\win32\NCScnet4.lib

and I modified the gdal/frmts/ecw/makefile.vc a bit to have:

EXTRAFLAGS = 	$(ECWFLAGS) \
		-I$(ECWDIR)\include -I$(ECWDIR)/Source/include \
		/D_MBCS /D_UNICODE /DUNICODE /D_WINDOWS \
		/DLIBECWJ2 /DWIN32 /D_WINDLL -DFRMT_ecw -DNO_X86_MMI

Key points are to ensure the NO_COMPRESS and ECWSDK_VERSION=4 are defined.

comment:4 Changed 9 years ago by warmerdam

Resolution: fixed
Status: newclosed

I have incorporated the ECW SDK 4.1 support in 1.7 branch as well (r20919) and built an OSGeo4W package.

It is expected that more comprehensive changes will be provided by Erdas at some point in the future.

comment:5 Changed 9 years ago by gabrimonfa

AFAIK ECW SDK 4.1 is only for Windows. Is it yet possible to use old ECW SDK 3.3 on Linux in 1.7 branch and in trunk?

Do you know of plans to extend support for Linux in ECW SDK 4.1, since sadly v.3.3 is no longer available for download?

comment:6 Changed 9 years ago by Even Rouault

gabrimonfa : generally questions should be asked to gdal-dev instead of in a (closed) Trac ticket. Yes, you can still build GDAL against the old ECW SDK 3.3 on Linux in both branches. As far as SDK 4.1 linux support is concerned, only Erdas can tell what their plan is.

Note: See TracTickets for help on using tickets.