Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3663 closed defect (fixed)

Warping a VRT (while extracting a sub area) generates an image with a NODATA bottom line

Reported by: ftrastour Owned by: warmerdam
Priority: normal Milestone:
Component: Utilities Version: 1.7.2
Severity: normal Keywords: gdalwarp
Cc:

Description

The context: gdlwarp is used to warp a VRT. The resulting image is only a portion of the input image : the option "-te" is used to delimit the area to warp. The extracted area is completly included within the input image.

The command is :

gdalwarp -t_srs "EPSG:32720" -te -225617.124201 8520166.546656 598743.538627 8933154.330544 -tr 500 -500 -ot Int16 -dstnodata -32768 -multi -r near srtm_sc.vrt dem_sc.tif

The gdalwarp used is the binary included in FWTools 2.4.7

The problem: The output image contains a bottom line filled with NODATA values.

The join zip file contains a small dataset reproducing the problem. Note that the 4 input images are empty (in order to be zipped efficiently ). I use openev to display the image and view the NODATA bottom line.

Attachments (1)

bug_warp.zip (415.4 KB) - added by ftrastour 12 years ago.
dataset reproducing the problem

Download all attachments as: .zip

Change History (4)

Changed 12 years ago by ftrastour

Attachment: bug_warp.zip added

dataset reproducing the problem

comment:1 Changed 12 years ago by warmerdam

Resolution: fixed
Status: newclosed

I have successfully reproduced the problem with FWTools 2.4.7 on linux, but I have not been able to reproduce it with the current development software. So I think this represents a bug that has already been fixed. I'd push out a new FWTools release for you, but it is no longer easy for me to produce FWTools releases.

comment:2 Changed 12 years ago by warmerdam

This bug sounds like #3658. With that in mind I tried reproducing it on linux with GDAL 1.7.2 "release" code but it worked fine. I will note I tried it without -multi in that case.

comment:3 Changed 12 years ago by Even Rouault

Actually I think this is the same as #3458 since I reproduce the issue with GDAL 1.7.1 but not with GDAL 1.7.2 and the issue with #3458 was missing lines of data. I'm not sure that #3658 is the same however

Note: See TracTickets for help on using tickets.