Opened 10 years ago

Closed 5 years ago

#3534 closed defect (fixed)

HDF5 driver fixes for subdataset name escaping and dimension capture

Reported by: warmerdam Owned by: warmerdam
Priority: normal Milestone: 1.8.1
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: hdf5
Cc: gaopeng, antonio

Description

Gao has incorporated several fixes in the 1.6-esri branch (r19406) for the HDF5 driver which should likely be forward ported to trunk once understood.

Change History (8)

comment:1 Changed 10 years ago by warmerdam

Status: newassigned

It should be noted that some of these changes were backed out and others added in 1.6-esri (r19408).

comment:2 Changed 10 years ago by warmerdam

and also r19409.

comment:3 Changed 10 years ago by warmerdam

The majority of fixes have been incorporated in trunk (r19431) with this explanation:

Avoid setting bogus projection if we don't get georeferencing from CreateProjections?(). Avoid trying to operate if DeltaLat/Lon? is zero. Avoid crashing on NULL poH5Object->pszPath in CreateMetadata?().

I am still reviewing the parsing of the subdataset name. PRESERVESCAPES was used, but I suspect it was to avoid losing backslashes in the name when the proper approach would have been to escape them in the first place.

comment:4 Changed 10 years ago by warmerdam

Gao,

I have been unable to reproduce problems windows with backslash handling in tokenizing on windows and filenames - at least on windows - are not permitted to have embedded double quotes. Can you provide details on why the PRESERVEESCAPES change was needed?

comment:5 Changed 10 years ago by gaopeng

The problem subdataset name is generated and returned from the driver itself when opening some HDF5 files.

comment:6 Changed 8 years ago by antonio

Cc: antonio added

comment:7 Changed 5 years ago by Jukka Rahkonen

Majority of fixes were incorporated 5 years ago with r19431. Some thinking was going on about PRESERVEESCAPES. Perhaps this ticket is still mature enough for closing.

comment:8 Changed 5 years ago by Jukka Rahkonen

Resolution: fixed
Status: assignedclosed

Closing as fixed because at least most issues in this ticket has been fixed. Better to create a new ticket about what remained if needed.

Note: See TracTickets for help on using tickets.