Opened 12 years ago

Closed 11 years ago

#3520 closed defect (fixed)

Lambert_Conformal_Conic_1SP incorrectly read as Lambert_Conformal_Conic_2SP by netcdf driver

Reported by: lpinner Owned by: Kyle Shannon
Priority: normal Milestone: 1.8.0
Component: GDAL_Raster Version: 1.7.1
Severity: normal Keywords: netcdf
Cc:

Description

Lambert_Conformal_Conic_1SP incorrectly read as Lambert_Conformal_Conic_2SP by netcdf driver

NetCDF subdataset has the following projection def (from ncdump):

char Lambert_Conformal_projection ;
    Lambert_Conformal_projection:grid_mapping_name = "lambert_conformal_conic" ;
    Lambert_Conformal_projection:standard_parallel = 25. ;
    Lambert_Conformal_projection:longitude_of_central_meridian = -95. ;
    Lambert_Conformal_projection:latitude_of_projection_origin = 25. ;
    Lambert_Conformal_projection:GRIB_earth_shape = "spherical" ;
    Lambert_Conformal_projection:GRIB_earth_shape_code = 0 ;

gdalinfo projection output is:

Coordinate System is:
PROJCS["unnamed",
    GEOGCS["WGS 84",
        DATUM["WGS_1984",
            SPHEROID["WGS 84",6378137,298.257223563,
                AUTHORITY["EPSG","7030"]],
            TOWGS84[0,0,0,0,0,0,0],
            AUTHORITY["EPSG","6326"]],
        PRIMEM["Greenwich",0,
            AUTHORITY["EPSG","8901"]],
        UNIT["degree",0.0174532925199433,
            AUTHORITY["EPSG","9108"]],
        AUTHORITY["EPSG","4326"]],
    PROJECTION["Lambert_Conformal_Conic_2SP"],
    PARAMETER["standard_parallel_1",0],
    PARAMETER["standard_parallel_2",0],
    PARAMETER["latitude_of_origin",25],
    PARAMETER["central_meridian",0],
    PARAMETER["false_easting",0],
    PARAMETER["false_northing",0]]

Attachments (1)

gph.nc.tar.gz (279.1 KB) - added by lpinner 12 years ago.
NetCDF dataset

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by lpinner

Attachment: gph.nc.tar.gz added

NetCDF dataset

comment:1 Changed 11 years ago by Kyle Shannon

Cc: Kyle Shannon added
Keywords: netcdf added
Milestone: 1.8.0
Owner: changed from warmerdam to Kyle Shannon

This was fixed in r18931 in the trunk. It works on my machine with 1.8.0dev. I did not backport this changeset to 1.7

comment:2 Changed 11 years ago by Kyle Shannon

Cc: Kyle Shannon removed

comment:3 Changed 11 years ago by Kyle Shannon

My mistake, it was r18896 where i commited the change. This is also a duplicate of #3324.

comment:4 Changed 11 years ago by Kyle Shannon

Resolution: fixed
Status: newclosed

Going to go ahead and close this ticket as fixed in r18896

Note: See TracTickets for help on using tickets.