Opened 10 years ago

Closed 10 years ago

#3448 closed defect (duplicate)

gdal_translate Georaster to HFA format, the major GIS software can't open!

Reported by: bicealyh Owned by: warmerdam
Priority: normal Milestone:
Component: GDAL_Raster Version: svn-trunk
Severity: major Keywords: HFA
Cc:

Description (last modified by warmerdam)

I use below command to export raster data from Georaster,but the major GIS software can't open it, like ArcMap? 9.3 or Erdas 8.5. The command like below:

gdal_translate -of HFA -srcwin 12140 0 3035 2304 geor:sde/sde@localhost:1521/ORCL,SDE.CITY_IMAGES_RDT,10 G:\test\Extract_10_5clip.img

The gdalinfo like below:

Driver: HFA/Erdas Imagine Images (.img)                                     
Files: G:\test\Extract_10_2clip.img                                                
G:\test\Extract_10_2clip.img.aux.xml                                 
Size is 3035, 2304                                                          
Coordinate System is:                                                       
GEOGCS["GCS_WGS_1984",                                                          
DATUM["WGS_1984",                                                               
SPHEROID["WGS_1984",6378137,298.25...]],                            
PRIMEM["Greenwich",0],                                                      
UNIT["Degree",0.01745....]]                                    
Origin = (112.563...,37.86..)                           
Pixel Size = (0.000000909090833,-0.000000909090833)                         
Corner Coordinates:                                                         
Upper Left  ( 112.56...,  37.86...)      
Lower Left  ( 112.56...,  37.86...)     
Upper Right ( 112.56...,  37.86...)     
Lower Right ( 112.56...,  37.86...)     
Center      ( 112.56...,  37.86...)    
Band 1 Block=64x64 Type=Byte, ColorInterp=Undefined                           
Metadata:                                                                     
LAYER_TYPE=athematic                                                    
Band 2 Block=64x64 Type=Byte, ColorInterp=Undefined                           
Metadata:                                                                     
LAYER_TYPE=athematic                                                    
Band 3 Block=64x64 Type=Byte, ColorInterp=Undefined                           
Metadata:                                                                     
LAYER_TYPE=athematic   

Attachments (2)

Extract_10_1clip.img (255.3 KB) - added by bicealyh 10 years ago.
Extract_10_1clip.img.aux.xml (273 bytes) - added by bicealyh 10 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by warmerdam

Component: defaultGDAL_Raster
Description: modified (diff)
Keywords: HFA added; Georaster removed
Milestone: 1.8.0
Status: newassigned

Hi,

Could you please ensure that this is not a duplicate of ticket #3382? You have indicated you are using svn-trunk, but has it been updated since February 4th when r18728 was applied to fix the problem?

If so, please supply (attach) a small .img file that you generate this way. You can use the -srcwin switch to gdal_translate to extract a subarea. I am doubtful this issue has anything to do specifically with georaster.

Changed 10 years ago by bicealyh

Attachment: Extract_10_1clip.img added

Changed 10 years ago by bicealyh

comment:2 Changed 10 years ago by bicealyh

This is not the same problem.

comment:3 Changed 10 years ago by Even Rouault

Resolution: duplicate
Status: assignedclosed

Yong Heng,

I'm pretty sure you have not use a recent enough svn-trunk nor GDAL 1.7.1 to generate this file.

gdalinfo should report "Description = Layer_1" in the metadata of band 1, which he doesn't on your sample file. So this is really the symptom of #3382

With latest svn-trunk, I've run : gdal_translate Extract_10_1clip.img out.img -of HFA

and gdalinfo on out.img reports "Description = Layer_1" as expected.

Closing as a duplicate of #3382

Note: See TracTickets for help on using tickets.