Opened 11 years ago

Closed 11 years ago

#3408 closed defect (fixed)

Looks like the fix to California EPSG to Stateplane was accidentally backed out

Reported by: gaige Owned by: warmerdam
Priority: normal Milestone: 1.7.2
Component: OGR_SRS Version: svn-trunk
Severity: major Keywords: stateplane
Cc:

Description

Changeset 9546 (Fixed California VII to point to fixed EPSG code)

swapped the EPSG code from the deprecated 26747 to the new 26799

It appears that a few months later, this was lost in an upgrade.

==== /data/stateplane.csv
138c138
< 10407,CALIFORNIA,VII,2,NAD27,407,26747
---
> 10407,CALIFORNIA,VII,2,NAD27,407,26799

Change History (1)

comment:1 Changed 11 years ago by warmerdam

Component: defaultOGR_SRS
Keywords: stateplane added
Resolution: fixed
Status: newclosed

The problem is that stateplane.csv comes from upstream in libgeotiff. I have applied http://trac.osgeo.org/geotiff/changeset/1815 in libgeotiff which restores two fixed previously done in GDAL, r9546 mentioned above, and r12605 done for #1944.

I have pulled the fixed file back into GDAL trunk (r18798) and 1.7 branch (r18799).

As long as we remember to apply stateplane.csv fixes upstream in libgeotiff in the future we should be ok.

Note: See TracTickets for help on using tickets.