Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3373 closed enhancement (duplicate)

Make worldfile priority configurable

Reported by: craigleat Owned by: warmerdam
Priority: normal Milestone: 1.8.0
Component: GDAL_Raster Version: svn-trunk
Severity: normal Keywords: worldfile
Cc:

Description

When reading a raster dataset GDAL currently only uses the ESRI worldfile as a fall-back if georeferencing is not found in the raster file. This approach assumes that a user wants the internal georeferencing. I think this assumption is too strict and at least three use cases exist where it is desirable to override the internal georeferencing.

  1. The creator of a read only dataset inserted an incorrect parameter(s) into the georeferencing string.
  2. The dataset was created with false eastings or northings and you wish to use it without these shifts. Think of overlaying data from different providers.
  3. You wish to use data created in standard Transverse Mercator in the south orientated Transverse Mercator projection. Only a change of sign is required and this is easily achieved via a worldfile.

The above requirements can be achieved using the virtual raster driver (.vrt), but somehow the prevalence of worldfiles is more prolific. If an environment variable (WORLDFILE_PRIORITY) existed the priority would at least be configurable and the default would be unset hence no priority.

Change History (2)

comment:1 Changed 10 years ago by warmerdam

Resolution: duplicate
Status: newclosed

Duplicate of #3374.

comment:2 in reply to:  1 Changed 10 years ago by craigleat

Replying to warmerdam:

Duplicate of #3374.


Thanks for closing this. I was suffering with internet connection problems yesterday.

Note: See TracTickets for help on using tickets.