Opened 10 years ago

Closed 7 years ago

#3315 closed defect (fixed)

VFK : errors reported by test_ogrsf utility

Reported by: Even Rouault Owned by: martinl
Priority: normal Milestone:
Component: OGR_SF Version: svn-trunk
Severity: normal Keywords: VFK
Cc: Even Rouault

Description

To check it : go in apps, and 'make test_ogrsf' then run test_ogrsf on your test .vfk file. This utility can be used to check the conformance of drivers to a few expected behaviours. Attached the report I got.

I've noticed a few errors, among them :

1) the ones about 'Feature SRS differs from layer SRS' are IMHO relatively minor. It means you need to do poGeom->assignSpatialReference(poSRS) as far as I remember

2) the one about 'GetFeatureCount?() may not be taking spatial filter into account' suggests that in your implementation of ::GetFeatureCount?(), you should propably default to call OGRLayer::GetFeatureCount?() when a spatial filter has been set. This will default to the dummy, but safe, implementation that iterates on all the features with GetNextFeature?() and count them

3) there's one : 'ERROR: Claimed feature count 13 doesn't match actual, 26.' . I'm not sure why. The test does a ResetReading?() and then iterate on GetNextFeature?() and compares the number of iterations to GetFeatureCount?(). Perhaps an issue with GetFeatureCount?() on that particular layer ?

Note: test_ogrsf was segfaulting because an old bug I've fixed in latest revision in r18471

Attachments (1)

log_test_ogrsf.txt (17.3 KB) - added by Even Rouault 10 years ago.
Log of test_ogrsf debug utility on bylany.vfk

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by Even Rouault

Attachment: log_test_ogrsf.txt added

Log of test_ogrsf debug utility on bylany.vfk

comment:1 Changed 10 years ago by Even Rouault

Cc: Even Rouault added
Component: defaultOGR_SF
Keywords: VFK added
Owner: changed from warmerdam to martinl
Version: unspecifiedsvn-trunk

comment:2 Changed 10 years ago by martinl

Status: newassigned

1) and 2) fixed in r18475.

3)

Linear features in SBP layer are formed by more records (each record determines one vertex). In this case all lines are formed by two vertices. Number features/records 13/26.

Martin

comment:3 Changed 7 years ago by martinl

Resolution: fixed
Status: assignedclosed

Seems to be fixed. Closing the ticket.

Note: See TracTickets for help on using tickets.