Opened 10 years ago

Closed 9 years ago

#3277 closed defect (fixed)

using gdal_translate insert raster to georaster error

Reported by: bicealyh Owned by: ilucena
Priority: high Milestone: 1.7.0
Component: GDAL_Raster Version: svn-trunk
Severity: major Keywords: georaster
Cc: warmerdam

Description (last modified by warmerdam)

D:>gdal_translate  -of georaster G:\img\test.img georaster:user/password@dbname,city_images,image -a_nodata 256 -co "DESCRIPTION=(image_id NUMBER, filename VARCHAR2(200), image MDSYS.SDO_GEORASTER,FOOTPRINT MDSYS.SDO_GEOMETRY,OBJECTID NUMBER(38),SE_ANNO_CAD_DATA BLOB)" -co "INSERT=VALUES( 5,'part4_10.img',SDO_GEOR.INIT('city_images_rdt',5),null,5,null)" -co "BLOCKXSIZE=256" -co "BLOCKYSIZE=256" -co "COMPRESS=NONE" -co "BLOCKBSIZE=1" -co "INTERLEAVE=BSQ"                                                                  Input file size is 11238, 10548                                                 0...10...20...30...40...50...60...70...80...90...100 - done.                    Ouput dataset: (georaster:sde,sde,ORCL,CITY_IMAGES_RDT,5) on SDE.CITY_IMAGES,IMAGE                                                                ERROR 1: ORA-31011: XML Parsing failed                                            
ORA-19202: XML processing                                                             
LPX-00245: After the end tag in the document there is redundant data                                      
Error at line 49                                                                 
时出错                                                                         
ORA-06512: 在 "SYS.XMLTYPE", line 310                                           
ORA-06512: 在 line 8                                        

Change History (4)

comment:1 Changed 10 years ago by warmerdam

Cc: warmerdam added
Description: modified (diff)
Keywords: georaster added
Owner: changed from warmerdam to ilucena

comment:2 Changed 10 years ago by ilucena

Status: newassigned

The problem seems to be caused by the attempt to load the HFA RAT as Oracle's VAT when it is only a histogram, not really an attribute table. That was fixed on http://trac.osgeo.org/gdal/changeset/17421.

comment:3 Changed 9 years ago by ilucena

The revision r19946 change the way VAT is update. Please try again and in case of error, please provide a small sample file so that we can replicate the problem.

One way to do that:

gdal_translate -of hfa G:\img\test.img G:\img\test2.img -outsize 64 64

comment:4 Changed 9 years ago by ilucena

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.