Opened 10 years ago

Closed 10 years ago

#3086 closed defect (fixed)

Equidistant Conic ESRI Morphing Broken

Reported by: warmerdam Owned by: warmerdam
Priority: normal Milestone: 1.6.2
Component: OGR_SRS Version: 1.5.3
Severity: normal Keywords: equidistant_conic
Cc: vjetly

Description

testepsg EPSG:102010 produces invalid results.

OGRSpatialReference::Validate: PARAMETER Central_Meridian for PROJECTION Equidistant_Conic is an alias for longitude_of_center.
Validate Fails.
WKT[EPSG:102010] =
PROJCS["North_America_Equidistant_Conic",
    GEOGCS["GCS_North_American_1983",
        DATUM["North_American_Datum_1983",
            SPHEROID["GRS_1980",6378137,298.257222101]],
        PRIMEM["Greenwich",0],
        UNIT["Degree",0.017453292519943295]],
    PROJECTION["Equidistant_Conic"],
    PARAMETER["False_Easting",0],
    PARAMETER["False_Northing",0],
    PARAMETER["Central_Meridian",-96],
    PARAMETER["Standard_Parallel_1",20],
    PARAMETER["Standard_Parallel_2",60],
    PARAMETER["Latitude_Of_Origin",40],
    UNIT["Meter",1],
    AUTHORITY["EPSG","102010"]]

Simplified WKT[EPSG:102010] =
PROJCS["North_America_Equidistant_Conic",
    GEOGCS["GCS_North_American_1983",
        DATUM["North_American_Datum_1983",
            SPHEROID["GRS_1980",6378137,298.257222101]],
        PRIMEM["Greenwich",0],
        UNIT["Degree",0.017453292519943295]],
    PROJECTION["Equidistant_Conic"],
    PARAMETER["False_Easting",0],
    PARAMETER["False_Northing",0],
    PARAMETER["Central_Meridian",-96],
    PARAMETER["Standard_Parallel_1",20],
    PARAMETER["Standard_Parallel_2",60],
    PARAMETER["Latitude_Of_Origin",40],
    UNIT["Meter",1]]

Old Style WKT[EPSG:102010] = PROJCS["North_America_Equidistant_Conic",GEOGCS["GCS_North_American_1983",DATUM["North_American_Datum_1983",SPHEROID["GRS_1980",6378137,298.257222101]],PRIMEM["Greenwich",0],UNIT["Degree",0.017453292519943295]],PROJECTION["Equidistant_Conic"],PARAMETER["False_Easting",0],PARAMETER["False_Northing",0],PARAMETER["Central_Meridian",-96],PARAMETER["Standard_Parallel_1",20],PARAMETER["Standard_Parallel_2",60],PARAMETER["Latitude_Of_Origin",40],UNIT["Meter",1]]
ESRI'ified WKT[EPSG:102010] = 
PROJCS["North_America_Equidistant_Conic",
    GEOGCS["GCS_North_American_1983",
        DATUM["D_North_American_1983",
            SPHEROID["GRS_1980",6378137,298.257222101]],
        PRIMEM["Greenwich",0],
        UNIT["Degree",0.017453292519943295]],
    PROJECTION["Equidistant_Conic"],
    PARAMETER["False_Easting",0],
    PARAMETER["False_Northing",0],
    PARAMETER["Central_Meridian",-96],
    PARAMETER["Standard_Parallel_1",20],
    PARAMETER["Standard_Parallel_2",60],
    PARAMETER["Latitude_Of_Origin",40],
    UNIT["Meter",1]]
PROJ.4 rendering of [EPSG:102010] = +proj=eqdc +lat_0=0 +lon_0=0 +lat_1=20 +lat_2=60 +x_0=0 +y_0=0 +ellps=GRS80 +datum=NAD83 +units=m +no_defs 

In particular longitude_of_origin and latitude_of_origin are improperly expressed as central_meridian and latitude_of_origin in OGR format.

Tested in trunk, not sure if this is an old problem.

Change History (2)

comment:1 Changed 10 years ago by warmerdam

Milestone: 1.6.2
Status: newassigned
Version: unspecified1.5.3

I have confirmed that this problem has existed since 1.5.

comment:2 Changed 10 years ago by warmerdam

Resolution: fixed
Status: assignedclosed

It turns out the problem is really just in the gdal/data/esri_extra.wkt dictionary which was generated a long time ago. The morph methods seem ok now. I have hand edited all the equidistant_conic definitions in the file and fixed in trunk (r17473) and 1.6 (r17474). The change will make 1.6.2.

As a work around anyone can substitute http://svn.osgeo.org/gdal/trunk/gdal/data/esri_extra.wkt for their current dictionary.

Note: See TracTickets for help on using tickets.