Opened 12 years ago

Closed 12 years ago

#3082 closed defect (fixed)

HFA driver : Writing internal histogram not working ?

Reported by: Even Rouault Owned by: warmerdam
Priority: normal Milestone: 1.7.0
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: HFA
Cc:

Description

Scenario to reproduce :

gdal_translate -of HFA ../autotest/gdrivers/data/87test.img tmp.img
rm tmp.img.aux.xml
gdalinfo tmp.img

This returns :

[snip]
    STATISTICS_HISTONUMBINS=0
    STATISTICS_HISTOMIN=0
    STATISTICS_HISTOMAX=244
    LAYER_TYPE=athematic
    STATISTICS_HISTOBINVALUES=
<GDALRasterAttributeTable>
  <FieldDefn index="0">
    <Name>Histogram</Name>
    <Type>0</Type>
    <Usage>0</Usage>
  </FieldDefn>
</GDALRasterAttributeTable>

whereas gdalinfo original 87test.img shows :

[snip]
    STATISTICS_HISTOMIN=0
    STATISTICS_HISTOMAX=244
    STATISTICS_HISTOBINVALUES=0|0|0|0|0|2|1|0|1|1|1|1|3|9|12|17|25|44|48|23|23|
11|5|7|5|2|3|4|3|4|1|2|1|1|1|0|2|4|2|2|3|4|0|1|3|1|1|1|4|3|4|1|1|3|0|0|1|0|0|2|
0|1|0|1|1|1|2|2|1|0|2|1|0|1|0|0|0|0|1|0|1|1|1|1|0|2|1|0|1|0|1|0|1|0|0|2|0|1|0|0|
0|1|1|0|1|0|1|0|1|0|2|1|0|0|0|1|0|0|0|0|0|0|2|0|1|0|0|0|1|0|1|0|0|2|1|0|0|1|1|0|
0|1|0|0|0|1|0|0|0|1|1|0|0|1|1|0|0|0|1|1|0|0|0|1|0|0|1|1|0|1|0|0|0|0|0|0|0|1|1|0|
1|0|1|0|0|2|0|0|1|1|0|0|0|1|0|2|1|0|0|2|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|0|1|0|0|0|
0|0|0|0|0|0|1|0|0|1|0|0|0|0|0|0|0|0|0|0|0|0|2|1|2|
<GDALRasterAttributeTable>
  <FieldDefn index="0">
    <Name>BinValues</Name>
    <Type>1</Type>
    <Usage>5</Usage>
  </FieldDefn>
  <FieldDefn index="1">
    <Name>Histogram</Name>
    <Type>1</Type>
    <Usage>0</Usage>
  </FieldDefn>
  <Row index="0">
    <F>5</F>
    <F>2</F>
  </Row>
[snip]
  <Row index="114">
    <F>244</F>
    <F>2</F>
  </Row>
</GDALRasterAttributeTable>

Change History (1)

comment:1 Changed 12 years ago by warmerdam

Keywords: HFA added
Milestone: 1.7.0
Resolution: fixed
Status: newclosed

The problem was incomplete population of histogram related metadata for the unique values case. Corrected in trunk (r17471) and 1.6-esri (r17472).

Note: See TracTickets for help on using tickets.