Opened 10 years ago

Closed 10 years ago

#3067 closed defect (fixed)

GTiffDataset::FlushCache() cause crashes when used just after dataset creation

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 1.6.2
Component: default Version: 1.6.0
Severity: normal Keywords:
Cc:

Description

The following snippet causes a crash :

import gdal
ds = gdal.GetDriverByName('GTiff').Create('test.tif', 1, 1, 1)
ds.FlushCache()
ds = None

The crash occurs in the dataset destruction. But errors are issued in FlushCache?(). The root of the problem is that in this context FlushCache?() calls FlushDirectory?(), without any prior SetDirectory?().

Change History (1)

comment:1 Changed 10 years ago by Even Rouault

Resolution: fixed
Status: newclosed
Summary: GTiffDataset::FlushCache() cause crashes when used just after datasetGTiffDataset::FlushCache() cause crashes when used just after dataset creation

Fixed in trunk (r17406) and branches/1.6 (r17407). Tested in r17408

Note: See TracTickets for help on using tickets.