Opened 12 years ago

Closed 12 years ago

#3055 closed defect (worksforme)

GTiffDriver : GDALCreate doesn't support TFW=YES option

Reported by: ftrastour Owned by: warmerdam
Priority: normal Milestone:
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: gtiff worldfile tfw
Cc:

Description

GDALCreate doesn't create the world file.

cause : The world file creation function GDALWriteWorldFile is called with an empty basename.

To reproduce the bug :

gdal_dem hillshade -co TFW=YES smalldem.tif smalldem_sh.tif 0...10...20...30...40...50...60...70...80...90...100 - done.

ls smalldem_sh.*

smalldem_sh.tif

Attachments (1)

smalldem.tif (4.3 KB) - added by ftrastour 12 years ago.
DEM That can be used with gdaldem to reproduce the bug

Download all attachments as: .zip

Change History (2)

Changed 12 years ago by ftrastour

Attachment: smalldem.tif added

DEM That can be used with gdaldem to reproduce the bug

comment:1 Changed 12 years ago by Even Rouault

Resolution: worksforme
Status: newclosed

Works for me with your sample image. Please ensure you're running against latest trunk or GDAL 1.6.1 (GDAL 1.6.0 had a problem with GDALCreate and -co TFW=YES. See http://trac.osgeo.org/gdal/ticket/2760)

Note: See TracTickets for help on using tickets.