Opened 15 years ago

Closed 13 years ago

#3039 closed defect (fixed)

Unnecessary PAM .aux.xml files written sometimes

Reported by: warmerdam Owned by: warmerdam
Priority: normal Milestone:
Component: GDAL_Raster Version: 1.6.1
Severity: normal Keywords: PAM
Cc:

Description

The command:

gdal_translate -of EHDR oddsize1bit.tif  ~/out2.bil

With the oddsize1bit.tif file from autotest/gcore/data results in a .bil file being produced with an associated .aux.xml containing:

<PAMDataset>
  <PAMRasterBand band="1">
    <Metadata domain="IMAGE_STRUCTURE">
      <MDI key="NBITS">1</MDI>
    </Metadata>
    <Metadata/>
  </PAMRasterBand>
</PAMDataset>

The problem seems to be that default copying of a dataset triggers unneeded calls to MarkPamDirty() and so the .aux.xml is written even though the only info it is is systematic data produced by the driver.

Change History (2)

comment:1 by Even Rouault, 14 years ago

This particular case is no longer reproduced in trunk

comment:2 by Even Rouault, 13 years ago

Milestone: 1.6.4
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.