Opened 13 years ago

Closed 3 years ago

#2773 closed defect (wontfix)

S-57 driver does not convert to UTF-8

Reported by: darkblueB Owned by: warmerdam
Priority: normal Milestone: closed_because_of_github_migration
Component: OGR_SF Version: svn-trunk
Severity: normal Keywords: S57
Cc:

Description

using ogr2ogr to generate KML from an ENC S-57 file, a Latin-1 degree sign (0xB0) is emitted, but KML is declared as utf-8. The result is an invalid KML file.

Attachments (1)

US2WC12M.zip (694.9 KB) - added by darkblueB 13 years ago.

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by darkblueB

Attachment: US2WC12M.zip added

comment:1 Changed 13 years ago by warmerdam

Cc: warmerdam added
Owner: changed from warmerdam to condit

Turning over to Chris to review.

I will note that the KML driver should assume that incoming text is valid UTF-8, and preserve it accordingly.

comment:2 Changed 13 years ago by warmerdam

Cc: warmerdam removed
Keywords: S57 added; KML removed
Owner: changed from condit to warmerdam

Actually, it would appear the problem is that the S-57 driver does not convert to UTF-8. Reassigning to myself. :-(

I do not anticipate correcting the problem in the near future as I'm really unclear on what encoding(s) are actually used in S-57 files.

comment:3 Changed 13 years ago by Even Rouault

Summary: KML Driver emits broken utf-8S-57 driver does not convert to UTF-8

comment:4 Changed 3 years ago by Even Rouault

Milestone: closed_because_of_github_migration
Resolution: wontfix
Status: newclosed

This ticket has been automatically closed because Trac is no longer used for GDAL bug tracking, since the project has migrated to GitHub?. If you believe this ticket is still valid, you may file it to https://github.com/OSGeo/gdal/issues if it is not already reported there.

Note: See TracTickets for help on using tickets.