Opened 13 years ago

Closed 12 years ago

#2723 closed defect (fixed)

Broken links to References in doxygen documentation

Reported by: winkey Owned by: warmerdam
Priority: normal Milestone:
Component: Docs Version: unspecified
Severity: normal Keywords:
Cc: Mateusz Łoskot

Description

[10:25:05] <winkey> go here http://gdal.org/gdal_8h.html#33b543bd0b1e36598abb7fa9fd39add7

[10:25:16] <winkey> click GDALGetDataTypeName()

[10:25:40] <winkey> or a few of the other links

[10:25:57] <EvenR> hum, links are broken ?

[10:26:06] <winkey> looks that way

[10:27:54] <EvenR> is that new?

[10:28:31] <winkey> unsure if ive been to this exact page before

[10:33:12] <EvenR> winkey: hum, I've generated the doxygen doc for branches/1.5 on my machine, and I get the same error... Either it has never worked, or it is due to an interaction with a recent doxygen

[10:33:47] <EvenR> I know that FrankW has moved the site to another machine as there was a disk crash

[10:34:01] <EvenR> maybe he uses a more recent doxygen too now

[10:34:10] <crschmidt> I think it was actually moved to the same machine with a new disk

[10:34:18] <crschmidt> but the doxygen version is newer

[10:35:06] <EvenR> the proble is that it doesn't generate the foo_8cpp-source.html files

[10:39:03] <winkey> ok i can submit a bug if i can quote this in it ;-)

[10:39:18] <winkey> cause without that i am clueless

[10:40:20] <EvenR> you can file a bug as I think it is somehow a regression due to doxygen upgrade (but not 100% sure). I know hardly any thing in Doxygen, so I'm not a great help for that.

Attachments (1)

doxyfile_19004.diff (1.4 KB) - added by winkey 12 years ago.
patch to fix broken links on references in doxygen docs

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by Mateusz Łoskot

Cc: Mateusz Łoskot added

comment:2 Changed 12 years ago by Mateusz Łoskot

Summary: broken documentationBroken links to References in doxygen documentation

comment:3 Changed 12 years ago by Even Rouault

reported as #3446 as well

comment:4 Changed 12 years ago by winkey

I had forgot I had even submitted this ticket

the problem is REFERENCES_LINK_SOURCE = NO must be included in the Doxyfile otherwise strange things seem to happen

patch against svn rev 19004 attatched

thanks,

brian

Changed 12 years ago by winkey

Attachment: doxyfile_19004.diff added

patch to fix broken links on references in doxygen docs

comment:5 Changed 12 years ago by warmerdam

Resolution: fixed
Status: newclosed

Patch applied (r19005), seems to have corrected the broken links.

Note: See TracTickets for help on using tickets.