Opened 14 years ago

Closed 14 years ago

#2605 closed defect (invalid)

gdal_merge.py stripping out color info

Reported by: mbuchoff Owned by: hobu
Priority: normal Milestone: 1.5.3
Component: PythonBindings Version: unspecified
Severity: normal Keywords:
Cc:

Description

Hi. I generated 2 bitmaps from CADRG's using:

gdal_translate.exe A.TOC output.bmp -sds

The output was:

Input file size is 6144, 7680 0...10...20...30...40...50...60...70...80...90...100 - done. Input file size is 6144, 1536 0...10...20...30...40...50...60...70...80...90...100 - done.

and output.bmp1 and output.bmp2 were generated, both with 24-bit color.

When I typed:

python gdal_merge.py output.bmp1 output.bmp2

I got back a file, out.tif that was black and white.

I've repeated this test using .png's and .tif's as intermediates, as well as using them out the final output format. I've also tried gdal_merge.py with just one input file, but no matter what, I still get a black and white image.

Is this an actual bug or could I be misconfigured (I'm working in Windows XP using GDAL 1.5.2). If so, is there a workaround for this?

Thanks in advance.

Michael Buchoff

Change History (1)

comment:1 by mbuchoff, 14 years ago

Resolution: invalid
Status: newclosed

Closing the bug report. It turned out that I just needed to delete the output file and add -pct at the end of the command.

Note: See TracTickets for help on using tickets.