Opened 11 years ago

Closed 11 years ago

#2596 closed defect (fixed)

NITF & PAM nodata values

Reported by: klaricmn Owned by: warmerdam
Priority: normal Milestone: 1.5.3
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: nitf
Cc:

Description

The NITF driver doesn't read no data values from PAM. See the following thread: http://lists.osgeo.org/pipermail/gdal-dev/2008-September/018471.html

This thread includes the diff that shows how the problem is fixed. I've verified that this fix works for me as well. A patch is attached.

Attachments (1)

nitf-nodata.patch (533 bytes) - added by klaricmn 11 years ago.

Download all attachments as: .zip

Change History (2)

Changed 11 years ago by klaricmn

Attachment: nitf-nodata.patch added

comment:1 Changed 11 years ago by warmerdam

Component: defaultGDAL_Raster
Keywords: nitf added
Milestone: 1.5.3
Resolution: fixed
Status: newclosed

Fixed in trunk (r15464) and 1.5 branch (r15465).

Note: See TracTickets for help on using tickets.