Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2571 closed defect (fixed)

ilwisdataset.cpp exports a global variable called 'line' (1.5 branch)

Reported by: Even Rouault Owned by: Even Rouault
Priority: normal Milestone: 1.5.3
Component: GDAL_Raster Version: 1.5.2
Severity: normal Keywords:
Cc: hamish_b@…

Description

Reported by Hamish <hamish_b@yahoo.com>
> Glynn wrote:
> > > > It's more likely that some other file also contains a symbol named
> > > > "line". But the only one which I can find is the line() function in
> > > > lib/driver/Polygon.c, and that isn't exported.
> Hamish:
> > > led me to determine that the commit in which the problem is first
> > > seen is r33287 (initial r.external backport).
> > > http://trac.osgeo.org/grass/changeset/33187
> > > 
> > > unfortunately it's a complicated commit.
> Glynn: 
> > In that case, it's almost certainly due to the fact that GDAL exports
> > a variable named "line".
> 
> $ nm /usr/lib/libgdal1.5.0.a | grep ' line'
> 00000000 B line
> 
> ?
>  
> > You might want to report this to the GDAL developers; most of the
> > other variables have names which are unlikely to accidentally
> > conflict, but "line" is likely to be quite a common variable name.
> 
> ok

Yes indeed. 'line' was declared in ilwisdataset.cpp. The problem only exists in 1.5 branch.

Change History (2)

comment:1 Changed 11 years ago by Even Rouault

Resolution: fixed
Status: newclosed

Fixed in branches/1.5 in r15380

comment:2 Changed 11 years ago by hamish

excellent. Thanks.

Hamish

Note: See TracTickets for help on using tickets.