Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#2564 closed defect (fixed)

warping CInt dataset (terrasar-x) results in only zeros

Reported by: vincentschut Owned by: Even Rouault
Priority: normal Milestone: 1.5.3
Component: default Version: svn-trunk
Severity: normal Keywords: warp complex
Cc: dron

Description

trying to warp a complex Int16 dataset (terrasar-x) with gdalwarp results in a correctly warped file, but filled with zeros. The dataset is georeferenced with gcp's. Gdal is from svn-trunk. The expected behaviour is of course having a correctly georeferenced dataset filled with correctly resampled complex int16 data instead of zeros.

Change History (3)

comment:1 Changed 11 years ago by Even Rouault

Owner: changed from warmerdam to Even Rouault
Status: newassigned

comment:2 Changed 11 years ago by Even Rouault

Cc: dron added
Keywords: warp complex added
Milestone: 1.5.3
Resolution: fixed
Status: assignedclosed

Several issues there.

  • An old issue with just CInt16. Fixed in trunk in r15307 and in branches/1.5 in r15308
  • A very recent issues due to optimizations that introduced a regression. Fixed in trunk in r15309.

comment:3 Changed 11 years ago by vincentschut

Fix confirmed by reporter. Thanks!

Note: See TracTickets for help on using tickets.