Opened 12 years ago

Closed 12 years ago

#2515 closed defect (invalid)

gdalwarp aborts

Reported by: timmie Owned by:
Priority: normal Milestone:
Component: Utilities Version: 1.4.0
Severity: normal Keywords: gdalwarp
Cc: warmerdam, frankie

Description (last modified by warmerdam)

*** glibc detected *** gdalinfo: free(): invalid next size (fast): 0x08053490 ***
======= Backtrace: =========
/lib/tls/i686/cmov/libc.so.6[0xb77b5a85]
/lib/tls/i686/cmov/libc.so.6(cfree+0x90)[0xb77b94f0]
/usr/lib/libstdc++.so.6(_ZdlPv+0x21)[0xb7980b11]
/usr/lib/libgdal1.5.0.so.1(_ZN10GDALDriverD0Ev+0x44)[0xb7c2c8b4]
/usr/lib/libgdal1.5.0.so.1(_ZN17GDALDriverManagerD0Ev+0x58)[0xb7c2d358]
/usr/lib/libgdal1.5.0.so.1(GDALDestroyDriverManager+0x24)[0xb7c2cae4]
gdalinfo[0x804aad8]
/lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0)[0xb7760450]
gdalinfo[0x8049871]
======= Memory map: ========
08048000-0804c000 r-xp 00000000 08:02 1042808    /usr/bin/gdalinfo
0804c000-0804d000 rw-p 00003000 08:02 1042808    /usr/bin/gdalinfo
0804d000-080d7000 rw-p 0804d000 00:00 0          [heap]
b4f00000-b4f21000 rw-p b4f00000 00:00 0 
b4f21000-b5000000 ---p b4f21000 00:00 0 
b505c000-b542b000 r-xp 00000000 08:02 1045084    /usr/lib/libxerces-c.so.27.0
b542b000-b545e000 rw-p 003cf000 08:02 1045084    /usr/lib/libxerces-c.so.27.0
b545e000-b553e000 r-xp 00000000 08:02 1044845    /usr/lib/libfftw3.so.3.1.2
b553e000-b5544000 rw-p 000e0000 08:02 1044845    /usr/lib/libfftw3.so.3.1.2
b5544000-b5571000 r-xp 00000000 08:02 97861      /lib/libncurses.so.5.6
b5571000-b5574000 rw-p 0002c000 08:02 97861      /lib/libncurses.so.5.6
b5574000-b59bb000 r-xp 00000000 08:02 1045107    /usr/lib/libgdal1.4.0.so.1.11.4
b59bb000-b5a0d000 rw-p 00446000 08:02 1045107    /usr/lib/libgdal1.4.0.so.1.11.4
b5a0d000-b5a50000 rw-p b5a0d000 00:00 0 
b5a64000-b5a65000 r-xp 00000000 08:02 1651313    /usr/lib/grass/lib/libgrass_linkm.6.3.0.so
b5a65000-b5a66000 rw-p 00000000 08:02 1651313    /usr/lib/grass/lib/libgrass_linkm.6.3.0.so
b5a66000-b5a6b000 r-xp 00000000 08:02 1651330    /usr/lib/grass/lib/libgrass_rtree.6.3.0.so
b5a6b000-b5a6c000 rw-p 00004000 08:02 1651330    /usr/lib/grass/lib/libgrass_rtree.6.3.0.so
b5a6c000-b5a7d000 r-xp 00000000 08:02 1651318    /usr/lib/grass/lib/libgrass_dig2.6.3.0.so
b5a7d000-b5a7e000 rw-p 00010000 08:02 1651318    /usr/lib/grass/lib/libgrass_dig2.6.3.0.so
b5a7e000-b5a92000 r-xp 00000000 08:02 1651325    /usr/lib/grass/lib/libgrass_dgl.6.3.0.so
b5a92000-b5a93000 rw-p 00013000 08:02 1651325    /usr/lib/grass/lib/libgrass_dgl.6.3.0.so
b5a93000-b5a9b000 r-xp 00000000 08:02 1651346    /usr/lib/grass/lib/libgrass_dbmiclient.6.3.0.so
b5a9b000-b5a9c000 rw-p 00007000 08:02 1651346    /usr/lib/grass/lib/libgrass_dbmiclient.6.3.0.so
b5a9c000-b5aa9000 r-xp 00000000 08:02 1651314    /usr/lib/grass/lib/libgrass_dbmibase.6.3.0.so
b5aa9000-b5aaa000 rw-p 0000c000 08:02 1651314    /usr/lib/grass/lib/libgrass_dbmibase.6.3.0.so
b5aaa000-b5ada000 r-xp 00000000 08:02 1651308    /usr/lib/grass/lib/libgrass_vect.6.3.0.so
b5ada000-b5adb000 rw-p 0002f000 08:02 1651308    /usr/lib/grass/lib/libgrass_vect.6.3.0.so
b5adb000-b5ae3000 r-xp 00000000 08:02 1651319    /usr/lib/grass/lib/libgrass_gproj.6.3.0.so
b5ae3000-b5ae4000 rw-p 00007000 08:02 1651319    /usr/lib/grass/lib/libgrass_gproj.6.3.0.so
b5ae4000-b5aeb000 r-xp 00000000 08:02 1651341    /usr/lib/grass/lib/libgrass_datetime.6.3.0.so
b5aeb000-b5aec000 rw-p 00006000 08:02 1651341    /usr/lib/grass/lib/libgrass_datetime.6.3.0.so
b5aec000-b5b34000 r-xp 00000000 08:02 1651348    /usr/lib/grass/lib/libgrass_gis.6.3.0.so
b5b34000-b5b35000 rw-p 00048000 08:02 1651348    /usr/lib/grass/lib/libgrass_gis.6.3.0.so
b5b35000-b5b3b000 rw-p b5b35000 00:00 0 
b5b3b000-b5b40000 r-xp 00000000 08:02 1651345    /usr/lib/grass/lib/libgrass_gmath.6.3.0.so
b5b40000-b5b41000 rw-p 00004000 08:02 1651345    /usr/lib/grass/lib/libgrass_gmath.6.3.0.so
b5b41000-b5b44000 r-xp 00000000 08:02 1651327    /usr/lib/grass/lib/libgrass_vask.6.3.0.so
b5b44000-b5b45000 rw-p 00003000 08:02 1651327    /usr/lib/grass/lib/libgrass_vask.6.3.0.so
b5b45000-b5b49000 rw-p b5b45000 00:00 0 
b5b49000-b5b4c000 r-xp 00000000 08:02 97809      /lib/libgpg-error.so.0.3.0
b5b4c000-b5b4d000 rw-p 00002000 08:02 97809      /lib/libgpg-error.so.0.3.0
b5b4d000-b5b98000 r-xp 00000000 08:02 98612      /lib/libgcrypt.so.11.2.3
b5b98000-b5b9a000 rw-p 0004a000 08:02 98612      /lib/libgcrypt.so.11.2.3
b5b9a000-b5b9b000 rw-p b5b9a000 00:00 0 
b5b9b000-b5baa000 r-xp 00000000 08:02 1043990    /usr/lib/libtasn1.so.3.0.12
b5baa000-b5bab000 rw-p 0000e000 08:02 1043990    /usr/lib/libtasn1.so.3.0.12
b5bab000-b5bc1000 r-xp 00000000 08:02 1044090    /usr/lib/libsasl2.so.2.0.22
b5bc1000-b5bc2000 rw-p 00015000 08:02 1044090    /usr/lib/libsasl2.Aborted


infos:
 dpkg -l|grep gdal
ii  gdal-bin                                   1.5.1-3                                  Geospatial Data Abstraction Library - Utilit
ii  libgdal1-1.4.0                             1.4.4-1ubuntu3                           Geospatial Data Abstraction Library
ii  libgdal1-1.4.0-grass                       1.4.4-1                                  GRASS extension for the Geospatial Data Abst
ii  libgdal1-1.5.0                             1.5.1-3                                  Geospatial Data Abstraction Library
ii  python-gdal                                1.5.1-3                                  Python bindings to the Geospatial Data Abstr

Change History (8)

comment:1 Changed 12 years ago by warmerdam

Cc: warmerdam added
Component: defaultUtilities
Description: modified (diff)
Keywords: gdalwarp added
Owner: changed from warmerdam to Mateusz Łoskot

Timmie,

We will need more information, such as the command line you used, the input data, etc.

Mateusz,

Turning over to you to follow up with Timmie and reproduce. There have been a number of fixes in the warper since 1.5.0, so keep in mind the problem might already be fixed.

comment:2 Changed 12 years ago by Even Rouault

Cc: frankie added

If you want my two cents, I'd bet this is still the problem that has been raised dozains of times. Timmie, I see you have libgdal1-1.4.0-grass installed but you're executing gdal-bin-1.5.1-3 utilities. If you remove the plugins compiled with 1.4 from /usr/lib/gdalplugins, it should work fine.

Frank, to avoid this, would it be possible to release a version of the grass plugin with the runtime check I've added in the initialization of the driver (GDAL_CHECK_VERSION macro). This way, we will avoid this problem to be reported again and again.

I also add the Debian packager, Francesco Lovergine, in CC to see if it can also be fixed at the distribution level. I'd suggest that the plugins for 1.5 are installed and searched in /usr/lib/gdalplugins-1.5 for example. A patch to GDALDriverManager::AutoLoadDrivers?() could do it, but this code looks a bit messy with many #ifdef.

comment:3 Changed 12 years ago by timmie

Hello, the qgis-grass-plugin on Ubuntu (maybe as well Debian) depends on libgdal1-1.4.0-grass. So removing it would also remove the Grass plugin for QGIS.

comment:4 Changed 12 years ago by Mateusz Łoskot

Timmie,

As Frank suggested, we are probably unable to reproduce your problem unless we get:

  • exact command you used
  • sample of your input data

Can you provide us with this?

comment:5 Changed 12 years ago by Mateusz Łoskot

Version: unspecified1.4.0

comment:6 Changed 12 years ago by Even Rouault

Timmie,

as I suggested, try removing libgdal1-1.4.0-grass (even if it removes temporarily the qgis-grass-plugin. Then you can reinstall it) to confirm that it fixes the crash. If so, this is a packaging issue that must be solved by installing only plugins depending of gdal 1.5.0 and removing older versions.

comment:7 Changed 12 years ago by Mateusz Łoskot

Owner: Mateusz Łoskot deleted

comment:8 Changed 12 years ago by Even Rouault

Resolution: invalid
Status: newclosed

Closing due to lack of feedback from reporter

Note: See TracTickets for help on using tickets.