Opened 11 years ago

Closed 11 years ago

#2471 closed defect (fixed)

Build pyramid crashes for this TIFF attached

Reported by: yanchen Owned by: warmerdam
Priority: high Milestone: 1.5.3
Component: GDAL_Raster Version: unspecified
Severity: normal Keywords: build pyramid HFA
Cc: swoo@…, gaopeng

Description

Inside HFADataset::IBuildOverviews function, ::GetRasterBand?() returns a NULL pointer for 2th band. Number of band is not correct.

When I debugged into HFAGetRasterInfo(), I found when .aux is read, hHFA->nBands is equal to 1.

Attachments (1)

DigitizingFeatures.zip (175.0 KB) - added by yanchen 11 years ago.
data

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by yanchen

Attachment: DigitizingFeatures.zip added

data

comment:1 Changed 11 years ago by warmerdam

Cc: gaopeng added; pgao@… removed
Keywords: HFA added
Owner: changed from Frank Waterdam to warmerdam
Priority: normalhigh

comment:2 Changed 11 years ago by warmerdam

Status: newassigned

It would be helpful to know what function, and arguments were used to create the overviews. I'm guessing some override config options are used to force use of aux/rrd overviews instead of TIFF overviews. Is that right?

comment:3 Changed 11 years ago by warmerdam

In experimenting with this file, a problem was identified with EXIF IFD handling in libtiff 4. A distinct bug in the libtiff bugzilla has been created for this issue.

http://bugzilla.maptools.org/show_bug.cgi?id=1917

I do not believe this is related to the problem you have encountered though, since I gather you are forcing HFA/AUX/RRD overview building.

comment:4 Changed 11 years ago by warmerdam

Problem reproduced using the command:

 gdaladdo --config USE_RRD YES DigitizingFeatures.tif 2 4

comment:5 Changed 11 years ago by warmerdam

The problem has been corrected in trunk (r14902) and 1.5 branch (r14903) by not accepting .aux files that have a different number of pixels, lines or bands than the dependent dataset in the findauxfiles function.

comment:6 Changed 11 years ago by warmerdam

Resolution: fixed
Status: assignedclosed

Added a test in trunk (r14904).

Note: See TracTickets for help on using tickets.