Opened 14 years ago

Closed 12 years ago

#1878 closed defect (fixed)

programs can't find .o when linking

Reported by: kyngchaos Owned by: dron
Priority: high Milestone: 1.6.1
Component: ConfigBuild Version: svn-trunk
Severity: major Keywords: libtool
Cc: warmerdam, hobu

Description

When building the programs (first one it tries is ogrinfo), the link stage tries to link the .o (ie ogrinfo.o) in the source dir. But these are in .libs/ and the .lo is the one in the source dir. So, it complains about a missing .o. It looks like from the makefile (ogr/gnumakefile) nothing has changed, so maybe libtool changed to now build .lo's (libtool v1.5.2 in GDAL 1.4, now v2.1 in trunk).

(cd ogr; make apps)

/bin/sh /Users/Shared?/src/gdal/gdal-svn-trunk-2007.09.29/libtool --mode=compile --tag=CXX /Users/kyngchaos/bin/c++ub -Wall -Os -Iogrsf_frmts -I. -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/port -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/gcore -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/alg -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/ogr -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/ogr/ogrsf_frmts -I/Library/Frameworks/PROJ.framework/unix/include -DPROJ_STATIC -DHAVE_GEOS=1 -I/Library/Frameworks/GEOS.framework/unix/include -DOGR_ENABLED -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/port -I/Library/Frameworks/UnixImageIO.framework/unix -I/Library/Frameworks/UnixImageIO.framework/unix/include -I/Library/Frameworks/UnixImageIO.framework/unix -I/Library/Frameworks/UnixImageIO.framework/unix/include -I/Library/Frameworks/UnixImageIO.framework/unix -I/Library/Frameworks/UnixImageIO.framework/unix/include -I/Users/Shared/unix/geotiff/include -I/Library/Frameworks/UnixImageIO.framework/unix/include -I/Library/Frameworks/UnixImageIO.framework/unix -I/Library/Frameworks/UnixImageIO.framework/unix/include -I/Users/Shared/unix/netcdf -I/Users/Shared/unix/netcdf/include -I/Users/Shared/unix/cfitsio -I/Users/Shared/unix/cfitsio/include -c -o ogrinfo.o ogrinfo.cpp

libtool: compile: /Users/kyngchaos/bin/c++ub -Wall -Os -Iogrsf_frmts -I. -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/port -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/gcore -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/alg -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/ogr -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/ogr/ogrsf_frmts -I/Library/Frameworks/PROJ.framework/unix/include -DPROJ_STATIC -DHAVE_GEOS=1 -I/Library/Frameworks/GEOS.framework/unix/include -DOGR_ENABLED -I/Users/Shared/src/gdal/gdal-svn-trunk-2007.09.29/port -I/Library/Frameworks/UnixImageIO.framework/unix -I/Library/Frameworks/UnixImageIO.framework/unix/include -I/Library/Frameworks/UnixImageIO.framework/unix -I/Library/Frameworks/UnixImageIO.framework/unix/include -I/Library/Frameworks/UnixImageIO.framework/unix -I/Library/Frameworks/UnixImageIO.framework/unix/include -I/Users/Shared/unix/geotiff/include -I/Library/Frameworks/UnixImageIO.framework/unix/include -I/Library/Frameworks/UnixImageIO.framework/unix -I/Library/Frameworks/UnixImageIO.framework/unix/include -I/Users/Shared/unix/netcdf -I/Users/Shared/unix/netcdf/include -I/Users/Shared/unix/cfitsio -I/Users/Shared/unix/cfitsio/include -c ogrinfo.cpp -fno-common -DPIC -o .libs/ogrinfo.o

/bin/sh /Users/Shared?/src/gdal/gdal-svn-trunk-2007.09.29/libtool --mode=link /Users/kyngchaos/bin/c++ub ogrinfo.o /Users/Shared?/src/gdal/gdal-svn-trunk-2007.09.29/libgdal.la -o ogrinfo

libtool: link: /Users/kyngchaos/bin/c++ub ogrinfo.o -o .libs/ogrinfo -Wl,-bind_at_load /Users/Shared?/src/gdal/gdal-svn-trunk-2007.09.29/.libs/libgdal.dylib -L/Library/Frameworks/PROJ.framework/unix/lib -L/Library/Frameworks/GEOS.framework/unix/lib -L/Users/Shared/unix/expat/lib -L/Library/Frameworks/Xerces.framework/unix/lib -L/Library/Frameworks/UnixImageIO.framework/unix -L/Library/Frameworks/UnixImageIO.framework/unix/lib -L/Users/Shared/unix/hdf/lib -L/Users/Shared/unix/ogdi -L/Users/Shared/unix/ogdi/lib -L/Users/Shared/unix/geotiff/lib -L/Users/Shared/unix/netcdf -L/Users/Shared/unix/netcdf/lib -L/Users/Shared/unix/cfitsio -L/Users/Shared/unix/cfitsio/lib -L/usr/local/pgsql/lib -L/Users/Shared/unix/dap/lib -lxml2 -liconv -L/Library/Frameworks/SQLite3.framework/unix/lib -L/Users/Shared/unix/mysql/lib/mysql -L/usr/lib -lproj -lgeos -lgeos_c -liodbc -liodbcinst -lxerces-c -ljasper -lmfhdf -ldf -logdi31 -lgif -ljpeg -lgeotiff -ltiff -lpng -lcfitsio -lpq -ldl -ldap -ldapserver -ldapclient /usr/lib/libxml2.dylib /usr/lib/libiconv.dylib -lpthread -lsqlite3 -lz -lm -lssl -lcrypto

powerpc-apple-darwin8-g++-4.0.1: ogrinfo.o: No such file or directory

i686-apple-darwin8-g++-4.0.1: ogrinfo.o: No such file or directory

lipo: can't figure out the architecture type of: /var/tmpcc3cdiTP.out

make[1]: * [ogrinfo] Error 1

make: * [ogr-apps] Error 2

Attachments (4)

gdal_make_15.patch (48.0 KB) - added by kyngchaos 13 years ago.
corrections made since first attachment
gdal_make_16.patch (74.9 KB) - added by kyngchaos 13 years ago.
patch for 1.6 beta 1
obj_make.diff (70.7 KB) - added by kyngchaos 12 years ago.
complete patch for 1.6.1
obj_sde.diff (255 bytes) - added by kyngchaos 12 years ago.
additional for sde makefile

Download all attachments as: .zip

Change History (34)

comment:1 Changed 14 years ago by kyngchaos

Ack! This goes beyond just the programs - all the dependencies in targets use .o. ie gcore:

default: $(OBJ)

When installing, this causes ALL sources to be rebuilt because the .o's are not found.

comment:2 Changed 14 years ago by kyngchaos

Priority: normalhigh

Sorry to bump the priority up, but this is a major nuisance (having both priority and severity is a bit confusing when reporting a bug).

I poked around a bit, and it seems that it's libtool. In GDAL 1.4, libtool copied each object file up 1 dir from .libs, so it's next to the source and the .lo. The new libtool 2 in GDAL SVN does not do this, thus make target dependencies don't see the .o object files.

comment:3 Changed 14 years ago by Mateusz Łoskot

Cc: Mateusz Łoskot added

comment:4 Changed 14 years ago by warmerdam

Cc: warmerdam added; Mateusz Łoskot removed
Keywords: libtool added
Owner: changed from warmerdam to Mateusz Łoskot

Mateusz,

Could you look into this? Perhaps there is some libtool option or something we should be using?

Also, could you confirm if this affects non-MacOSX platforms as well? I presume it must.

comment:5 Changed 14 years ago by Mateusz Łoskot

Status: newassigned

comment:6 Changed 14 years ago by Mateusz Łoskot

Resolution: worksforme
Status: assignedclosed

I can not reproduce this problem. I built GDAL 1.5.0 (SVN) and 1.4.4 using --with-libtool as well as using --without-libtool and both work for me well. I run test builds on clean source trees. Machine: Mac OS X 10.4

$ gcc --version
i686-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5367)

I'm closing this ticket as works for me. Please, reopen if it does not work for you.

comment:7 Changed 14 years ago by kyngchaos

I don't know what's up with my system. This started in OSX 10.4, and still happens (last check a couple weeks ago) in 10.5 in a migrated user environment. I have a clean environment (OSX 10.4) that I can try it in, just to make sure.

comment:8 Changed 13 years ago by kyngchaos

Milestone: 1.5.01.5.4
Resolution: worksforme
Status: closedreopened

Damn, forgot about this. I've been dealing with it.

So, still a problem. I verified on a clean system (10.4 and 10.5). Including framework, and standard library builds.

After some messing around now, I figured out how to get this to behave correctly (patch follows).

First, set a variable in gdalmake.opt to toggle the object file extension based on whether libtool is being used (OBJ_EXT).

Then, change all ".o" extensions in targets, single prerequisites and compile commands to $(OBJ_EXT). And change all multi-prerequisites to $(OBJ:.o=.$(OBJ_EXT)) or $(O_OBJ:.o=.$(OBJ_EXT)). See the patch for details.

I verified that this works on a clean make, and if make is halted and resumed, and on make install, on OSX 10.5. It shouldn't affect an ld-shared build, since all .o's will be .o. Windows VC build uses separate makefiles and shouldn't be affected. It needs to be checked on a linux libtool build.

This patch is for 1.5.3. A very similar patch would be needed for 1.6.0. I can work on that next, unless someone can take care of it when applying and checking the 1.5.3 patch.

Changed 13 years ago by kyngchaos

Attachment: gdal_make_15.patch added

corrections made since first attachment

Changed 13 years ago by kyngchaos

Attachment: gdal_make_16.patch added

patch for 1.6 beta 1

comment:9 Changed 13 years ago by warmerdam

Cc: hobu added

Howard,

Would you be in a position to apply and test these changes?

comment:10 Changed 13 years ago by hobu

William,

Are you provoking this when you do universal builds? A normal ./configure;make;make install doesn't cause me any problem on 10.5...

Howard

comment:11 Changed 13 years ago by kyngchaos

When I tested it on a clean Mac I left out the universal stuff. I used a minimal configure (not just ./configure on its own) - just the few formats that I can include from my frameworks.

..."normal" build... Aha!

One option I always use is --disable-static - static libs are completely useless in a framework. I just tried a build with a default static+dynamic (libtool) and now I get .o files directly alongside their sources. AND also the .lo + .libs/*.o. Programs linked successfully, and repeat make doesn't recompile everything.

So the static object files are compiled twice! (another reason for me to disable static) In the Terminal, for each source there are 2 compilations spun off the same libtool call from make - one compiling into .libs and one alongside the source. And, the target prerequisites appear to be based on the static (or ld-shared) build.

comment:12 Changed 13 years ago by warmerdam

I'm quite lost on this ticket. Is there anyone taking responsibility for the ticket now? The assignment to mloskot should be considered vestigial.

comment:13 Changed 13 years ago by kyngchaos

I can only provide patches. I figured Howard would verify my last discovery on OSX, can you verify on Linux (compile without static)? (I have a virtualized Ubuntu 8.04 I could try, but I haven't gotten up to speed on compiling software on that yet.)

comment:14 Changed 13 years ago by hobu

yes, I can verify patches on os x

comment:15 Changed 13 years ago by kyngchaos

How about the issue when leaving out static libs?

comment:16 Changed 13 years ago by dron

Milestone: 1.5.41.6.1
Owner: changed from Mateusz Łoskot to dron
Status: reopenednew

Folks,

Recently we hit the same issue here (broken linkage with --disable-static). So I've ported this patch for the current trunk and applied it (with few modifications, see r15888). I've tested both libtool and non-libtool builds and everything works smoothly. Please, verify that nothing is broken in your environments. I think it should go into 1.6 after that, because the issue is really important.

Thanks for the patch, William!

comment:17 Changed 13 years ago by dron

One more fix. r15892 removes module accidentally slipped into list of object files with the previous commit.

comment:18 Changed 13 years ago by Even Rouault

One more fix in r15893 for ogr/ogrsf_frmts/ogdi/GNUmakefile where an extra ')' was introduced

comment:19 Changed 12 years ago by hobu

What is the summary? r15888, r15892, and r15893 should be backported to 1.6, or this is all 1.7 stuff and the ticket should be kicked forward to 1.7?

comment:20 Changed 12 years ago by kyngchaos

I would like to see this in 1.6.1. PITA to compile otherwise.

comment:21 Changed 12 years ago by hobu

Is it possible to make a current patch that should be applied or is r15888, r15892 and r15893 sufficient?

comment:22 Changed 12 years ago by kyngchaos

They should cover it. There is some extra in the mrsid makefile that isn't really a part of this bug - for compiling as a plugin.

comment:23 Changed 12 years ago by hobu

William, can you try trunk with --with-tiff=internal and --with-geotiff=internal and --with-jpeg=internal. These patches don't seem to work when it comes to archive building time:

ar: /Users/hobu/svn/gdal_1_6/frmts/o/IdrisiDataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/IngrTypes.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/IntergraphBand.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/IntergraphDataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/JpegHelper.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/aigccitt.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/aigdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/aigopen.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/airsardataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/atlsci_spheroid.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/biggifdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/blx.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/blxdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/bmpdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/bsb_read.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/bsbdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/btdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/cache.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/ceos.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/ceosdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/ceosopen.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/ceosrecipe.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/ceossar.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/clock.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/cmplxpack.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/coasp_dataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/compack.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/comunpack.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/cosar_dataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/cpgdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/dataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/dec_jpeg2000.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/degrib1.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/degrib2.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/dgif_lib.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/dimapdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/dipxdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/doq1dataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/doq2dataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/drstemplates.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/egif_lib.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/ehdrdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/eirdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/enc_jpeg2000.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/engribapi.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/envidataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/ersdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/ershdrnode.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/fastdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/filedatasource.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/fileendian.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/fujibasdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_addfield.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_addgrid.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_addlocal.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_create.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_free.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_getfld.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_gribend.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_info.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_miss.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_unpack1.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_unpack2.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_unpack3.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_unpack4.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_unpack5.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_unpack6.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/g2_unpack7.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gbits.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gdalhttp.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/genbindataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geo_extra.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geo_free.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geo_get.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geo_names.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geo_new.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geo_normalize.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geo_print.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geo_set.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geo_tiffp.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geo_trans.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geo_write.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geotiff.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/geotiff_proj4.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/getdim.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/getpoly.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gff_dataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gif_err.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gifalloc.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gifdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/grib1tab.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/grib2api.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gribdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gridlib.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gridtemplates.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gscdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gt_overview.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/gt_wkt_srs.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/hfa_overviews.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/hfaband.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/hfacompress.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/hfadataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/hfadictionary.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/hfaentry.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/hfafield.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/hfaopen.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/hfatype.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/hkvdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/httpdriver.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/idadataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/int_power.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/inventory.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/isis2dataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/isis3dataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jaxapalsardataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jcdctmgr.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jchuff.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jcinit.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jcmainct.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jcmarker.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jcmaster.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jcomapi.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jcparam.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jcphuff.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jcprepct.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jcsample.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jctrans.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdapimin.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdapistd.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdatadst.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdatasrc.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdcoefct.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdcolor.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jddctmgr.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdhuff.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdinput.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdmainct.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdmarker.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdmaster.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdmerge.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdphuff.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdpostct.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdsample.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jdtrans.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jerror.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jfdctflt.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jfdctfst.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jfdctint.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jidctflt.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jidctfst.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jidctint.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jidctred.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jmemansi.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jmemmgr.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jpcpack.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jpcunpack.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jpgdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jquant1.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jquant2.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/jutils.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/landataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/lcpdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/levellerdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/link.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/md5.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/memdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/memendian.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/memorydatasource.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/metaname.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/metaparse.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/metaprint.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/mffdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/mgrs.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/minidriver.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/minidriver_tileservice.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/minidriver_wms.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/minidriver_worldwind.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/misspack.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/mkieee.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/mrsiddataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/mrsidstream.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/msg_basic_types.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/msg_reader_core.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/msgndataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/myassert.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/myerror.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/myutil.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/nasakeywordhandler.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/ndfdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/nitfaridpcm.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/nitfbilevel.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/nitfdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/nitffile.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/nitfimage.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/pack_gp.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/pauxdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/pdsdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/pdstemplates.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/pnmdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/rasterband.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/rawdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/rdieee.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/reduce.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/rpftocdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/rpftocfile.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/rs2dataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/sar_ceosdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/scan.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/seekgb.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/sgidataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/simpack.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/simunpack.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/specpack.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/specunpack.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/srtmhgtdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/stuff.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tdlpack.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/terragendataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_aux.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_close.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_codec.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_color.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_compress.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_dir.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_dirinfo.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_dirread.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_dirwrite.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_dumpmode.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_error.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_extension.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_fax3.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_fax3sm.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_float.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_flush.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_getimage.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_jpeg.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_luv.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_lzw.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_next.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_ojpeg.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_open.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_packbits.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_pixarlog.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_predict.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_print.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_read.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_strip.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_swab.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_thunder.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_tile.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_version.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_vsi.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_warning.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_write.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tif_zip.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tifvsi.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/tsxdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/vrtdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/vrtderivedrasterband.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/vrtdriver.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/vrtfilters.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/vrtrasterband.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/vrtrawrasterband.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/vrtsourcedrasterband.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/vrtsources.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/vrtwarped.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/vsidataio.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/wcsdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/weather.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/wmsdriver.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/xpmdataset.o: No such file or directory
ar: /Users/hobu/svn/gdal_1_6/frmts/o/xtiff.o: No such file or directory

It would seem there are places where hardcoded .o's still exist.

comment:24 Changed 12 years ago by kyngchaos

OK for me in trunk. I can try patching a copy of 1.6 svn tonight to see what happens. If I figure out something that works I'll post a patch here.

comment:25 Changed 12 years ago by kyngchaos

Well, a patched 1.6 svn works for me. I did have to manually patch 2 makefiles that failed the trunk diff: xplane and sde. I tried both the default shared+static library build, and disabling shared for static-only.

My configure:

./configure --with-threads --without-grass --without-jasper --with-libtiff=internal --with-jpeg=internal \
--with-gif=internal --with-png=internal --with-geotiff=internal --without-pg --without-mysql \
--without-sqlite3 --without-odbc --without-netcdf --without-hdf4 --without-hdf5 --with-pcraster=internal \
--without-cfitsio --with-geos=/Library/Frameworks/GEOS.framework/Programs/geos-config \
--with-static-proj4=/Library/Frameworks/PROJ.framework/unix --without-python --without-xerces

comment:26 Changed 12 years ago by hobu

Can you please attach the patch for the 1.6 branch? Maybe I'm not doing the merge correctly... 1.6.1 RC is planned for tomorrow.

Changed 12 years ago by kyngchaos

Attachment: obj_make.diff added

complete patch for 1.6.1

Changed 12 years ago by kyngchaos

Attachment: obj_sde.diff added

additional for sde makefile

comment:27 Changed 12 years ago by kyngchaos

Here you go. I had to do the sde makefile patch separately because patch wasn't handling dos line endings correctly, and you may have to apply it manually yourself.

comment:28 Changed 12 years ago by hobu

committed in the 1.6 branch in r16951. Please test and confirm.

comment:29 Changed 12 years ago by kyngchaos

Looks good. Test OK with shared-only build.

comment:30 Changed 12 years ago by Even Rouault

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.