Opened 13 years ago

Closed 13 years ago

#1636 closed defect (fixed)

Problems with multi-tile ycbcr encoded jpeg2000 data (JP2KAK)

Reported by: warmerdam Owned by: warmerdam
Priority: normal Milestone: 1.4.2
Component: GDAL_Raster Version: 1.4.0
Severity: normal Keywords: JP2KAK
Cc:

Description

Multi-tile jpeg2000 files that need to be decoded through ProcessYCbCrTile() are not being handled properly because the jpeg2000 tile offseting for the "primary request band" is being done in IReadBlock() but the same is not being done for the buffers from the block cache.

A patch addressing the issue is attached (provided by Daniel Lehman). The data file demonstrating the issue is not redistributable, and so is not attached.

Attachments (1)

jp2kakdataset.ALL.patch (2.5 KB) - added by warmerdam 13 years ago.
Proposed patch

Download all attachments as: .zip

Change History (2)

Changed 13 years ago by warmerdam

Attachment: jp2kakdataset.ALL.patch added

Proposed patch

comment:1 Changed 13 years ago by warmerdam

Resolution: fixed
Status: newclosed

A slightly modified variation of the patch has been applied in 1.4-esri (r11512), trunk (r11513) and 1.4 (r11514).

Note: See TracTickets for help on using tickets.