Opened 13 years ago

Closed 11 years ago

#1510 closed enhancement (duplicate)

new feature: OGRDataSource::DeleteLayer() for SHP data format

Reported by: gok@… Owned by: Mateusz Łoskot
Priority: normal Milestone:
Component: OGR_SF Version: 1.4.0
Severity: minor Keywords: shapefile
Cc: gok@…, warmerdam

Description (last modified by warmerdam)

Was trying to delete empty data set in SHP format (no spatial entities) and discovered that it is not handled by OGRDataSource::DeleteLayer(i).
Using unlink() command require multiple calls for each SHP collection (shp, dbf, shx, prj).

Change History (4)

comment:3 Changed 13 years ago by warmerdam

Description: modified (diff)
Milestone: 1.5.0

comment:4 Changed 13 years ago by warmerdam

Cc: warmerdam added
Component: defaultOGR_SF
Keywords: shapefile added
Owner: changed from warmerdam to Mateusz Łoskot

Turning over to Mateusz for implementation.

comment:5 Changed 13 years ago by warmerdam

Milestone: 1.5.01.6.0

comment:6 Changed 11 years ago by Even Rouault

Milestone: 1.6.1
Resolution: duplicate
Status: newclosed

Duplicate of #2561, which was implemented in 1.6.0

Note: See TracTickets for help on using tickets.