Opened 13 years ago

Closed 10 years ago

#1444 closed enhancement (worksforme)

SDE connection failed message non descriptive

Reported by: mchapman Owned by: mchapman
Priority: lowest Milestone: 1.6.1
Component: OGR_SF Version: 1.4.0
Severity: minor Keywords:
Cc: hobu

Description (last modified by warmerdam)

When trying to connect to sde in OGRSDEDataSource::Open() using an IP address the api returns an empty or non descriptive error making it appear as though a critical error occurred. The solution is to pass a server UNC or friendly name. This wasn't clear to me and I spent a little while trying to figure it out, so I thought by adding a check for an ip address or localhost it would be helpful to new users of the driver.

Is that ok with you Howard/Frank??

Change History (4)

comment:1 Changed 13 years ago by warmerdam

I'm all for more informative error messages.  Beyond that I have no opinion.
Adding Howard for comment.  


comment:4 Changed 13 years ago by warmerdam

Cc: hobu added
Description: modified (diff)
Milestone: 1.5.0

Really adding hobu this time.

comment:5 Changed 12 years ago by hobu

Milestone: 1.5.01.6.0

Martin,

I can connect to IP addresses as long as they are outside my local subnet and not in my windows domain, so maybe it has something to do with windows networking. On linux, I can definitely use 'localhost' as the server name (I run the server and test on a VMware instance ), so in both cases I really think the issue is windows related.

Pushing this one off into 1.6. Close if you wish.

comment:6 Changed 10 years ago by hobu

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.