Opened 13 years ago

Last modified 13 years ago

#1206 closed defect (duplicate)

gdaladdo issues with SRTM data

Reported by: tom.kralidis@… Owned by: warmerdam
Priority: high Milestone:
Component: GDAL_Raster Version: unspecified
Severity: major Keywords:
Cc:

Description

I am trying to generate a set of SRTM data via gdaltindex, for use with
MapServer, which has worked with no problems.

The next challenge is ensure they are displayed efficiently in MapServer, where
I have taken the following steps:

- run gdaltindex
- run gdaladdo on each image

When I try to run gdaladdo, I encounter the following issues:


Sample image:
ftp://ftp.glcf.umiacs.umd.edu/glcf/SRTM/Degree_Tiles/n045/SRTM_u01_n045w086/SRTM_u01_n045w086.tif.gz

$ gdaladdo -r average SRTM_u01_n045w086.tif 2 4 8 16 32
...
ERROR 1: IReadBlock failed at X offset 0, Y offset 11
ERROR 1: GetBlockRef failed at X block offset 0, Y block offset 1191
ERROR 1: SRTM_u01_n045w086.tif:DumpModeDecode: Not enough data for scanline 0
ERROR 1: TIFFReadEncodedTile() failed.

Change History (1)

comment:1 Changed 13 years ago by warmerdam

Tom,

William already submitted this, and I fixed it Saturday.  (not tested with
averaging but i think that should be fine).  See #1204. 

William has also filed Bug 1205 which is similar but relates to LZW compressed
files and overviews.  I don't think that comes into play with the SRTM.


*** This bug has been marked as a duplicate of 1204 ***
Note: See TracTickets for help on using tickets.