Opened 13 years ago

Closed 13 years ago

#231 closed defect (fixed)

Maptip.js \n replace problem in 1.1.1 and 2.0 beta

Reported by: amorsell Owned by: madair
Priority: P2 Milestone: 2.0
Component: Widgets Version: 1.1.1
Severity: Critical Keywords:
Cc: Browser: All
External ID: Operating System: All
state: New

Description

In Maptip.js (at least in 2.0 beta, a similar line exists in 1.1.1), line 185

contentDiv.innerHTML = t.replace(/\n/g, "<br>");

Should read:

contentDiv.innerHTML = t.replace(/
n/g, "<br>");

Otherwise the \n appears in the tooltips and the tooltip is one long string in MapGuide Open Source.

Change History (2)

comment:1 by amorsell, 13 years ago

Milestone: Future2.0
Severity: MinorCritical
Version: 1.1.1

comment:2 by madair, 13 years ago

Resolution: fixed
Status: newclosed

my testing couldn't reproduce the error but I've made the change anyway at rev 1927. I now looks like even without doing the <br> replacement that lines get split (FF3.5 and IE7 in any case)

Note: See TracTickets for help on using tickets.