Opened 13 years ago

Closed 13 years ago

#209 closed defect (fixed)

Measure Widget broken in IE7 when invoked from menu rather than toolbar

Reported by: chrisclaydon Owned by: madair
Priority: P1 Milestone: 2.0
Component: Widgets Version: SVN
Severity: Major Keywords:
Cc: Browser: All
External ID: 1166032 Operating System: All
state: Analysis Requested

Description

In the fusion-mg21 branch (probably in trunk too), when the Measure widget is invoked from the task pane task list menu, or from the map's right-click menu, it fails to work properly in IE7. The lines and segment labels do not get drawn.

It works better in Firefox, though it fails to pick up the units from the map correctly, so they show up as "unk" unless explicitly set using the Options dropdown.

Change History (4)

comment:1 by chrisclaydon, 13 years ago

FYI - This used to work in the previous version of Fusion. (Though the units were still not picked up correctly).

comment:2 by madair, 13 years ago

Status: newassigned

I'm unable to reproduce this in Fusion trunk, testing with IE7 and both the standard template and the slate template

comment:3 by chrisclaydon, 13 years ago

Perhaps the switch to the use of OpenLayers vectors in trunk has fixed the original issue.

comment:4 by pagameba, 13 years ago

Resolution: fixed
Status: assignedclosed

I think, in general, this was fixed in the OpenLayers update. However, in testing I found a JS error in IE7 and IE 8 in compatibility mode, fixed in r1873.

Note: See TracTickets for help on using tickets.