Opened 14 years ago

Closed 14 years ago

#18 closed enhancement (duplicate)

Auto-detect map object type

Reported by: jfournier Owned by: madair
Priority: P2 Milestone: 1.1
Component: Core Version: 1.0.2
Severity: Major Keywords:
Cc: Browser: All
External ID: Operating System: All
state: New

Description

With the new ApplicationDefinition structure, each WidgetSet corresponds to a single map object, which may refer to a Map by id. A Map contains Layer tags that each have a type that corresponds to an OpenLayers! type. Right now, the Map widget in the WidgetSet is still one of MGMap or MSMap. We'll need to make changes, at some point, to grab the layers from the Map and create the right OpenLayers Layer objects for them. I'd also like to consider how we could expose some sort of API to simplify (or make possible) adding a new Layer at runtime.

Change History (1)

comment:1 by pagameba, 14 years ago

Resolution: duplicate
Status: newclosed

Duplicate of #17.

Note: See TracTickets for help on using tickets.