Opened 14 years ago

Closed 14 years ago

#155 closed defect (fixed)

Layout fails to re-load when browser refresh button is pushed (in IE7 with default settings)

Reported by: chrisclaydon Owned by: madair
Priority: P1 Milestone: 2.0
Component: Core Version: SVN
Severity: Major Keywords:
Cc: Browser: All
External ID: 1152238 Operating System: All
state: Analysis Requested

Description

In IE7, load up a Fusion layout based on the Slate template. It should work the first time. Then click the browser's refresh button.

In IE7, the layout can fail to load after the refresh. It depends on the caching settings...

In IE, click on Tools->Internet Options, and on the 'General' tab, click on the Settings button in the 'Browsing history' section. In the 'Check for newer versions of stored pages' section, this problem occurs if the setting is 'Automatically', but does not occur if it is set to 'Every time I visit the webpage'.

Change History (8)

comment:1 by madair, 14 years ago

Status: newassigned

I'm unable to reproduce this. Using IE7, cache set to check automatically, I can see the traffic in Fiddler with many 304 responses. Is there some other setting in play here? Also tried disabling script debugging but the page always reloads for me.

comment:2 by chrisclaydon, 14 years ago

Are you retrieving the application definition from the MapGuide repository, or using the local ApplicationDefinition.xml?

comment:3 by madair, 14 years ago

Loading the AppDef from the repository gives the same results (i.e. can't reproduce the problem). I am launching the page by copy/paste of the URL from Studio 2009 into the browser (IE isn't my default browser, and I'm running into problems getting MG2010 Apacherunning).

comment:4 by chrisclaydon, 14 years ago

If I change the Slate template to link fusion.js, I can't reproduce it. If I change it back to fusionSF-compressed.js, I can.

comment:5 by madair, 14 years ago

(In [1655]) re #155: use setTimeout to call getAppDef so that ApplicationDefinition.parse will return before Fusion.setLaodState(LOAD_WIDGETS) gets called (otherwise Fusion.ApplicationDefinition is null). When the browser is set to read files from cache, the AppDef is retrieved from cache and the sequence of callbacks is executed too quickly

comment:6 by madair, 14 years ago

Resolution: fixed
Status: assignedclosed

comment:7 by chrisclaydon, 14 years ago

Resolution: fixed
Status: closedreopened

comment:8 by madair, 14 years ago

Resolution: fixed
Status: reopenedclosed

(In [1681]) closes #155: also break execution thread if session parameter is supplied

Note: See TracTickets for help on using tickets.