Opened 14 years ago

Closed 12 years ago

#141 closed defect (fixed)

Legend widget is not updating correctly

Reported by: CivilEng Owned by: madair
Priority: P2 Milestone: 2.0
Component: Widgets Version: 1.0.6
Severity: Critical Keywords:
Cc: Browser: All
External ID: Operating System: Windows
state: New

Description

The steps in order to replicate the issue are:

  1. To create a new session layer (programatically in MGOS).

  1. Next, user themes the new session layer (according to his/her preference) then, the map widget is updated correctly however the legend widget is updated incorrectly.

The ranks shows in the legend widget are correct but the colors are wrongs.

I have used reloadMap since is the unique way of updating the legend programatically. What it happening is that the browser is caching the legend images from previos theme. When the browser cache is deleted then the legend widget is painted correctly.

Attachments (1)

VentanillaFUSIONissue.JPG (73.3 KB ) - added by CivilEng 14 years ago.

Download all attachments as: .zip

Change History (7)

by CivilEng, 14 years ago

Attachment: VentanillaFUSIONissue.JPG added

comment:1 by madair, 13 years ago

Owner: changed from pspencer to madair
Status: newassigned

restored a 'noCache' flag for the legend URL. I'm not able to test your use-case directly so please test again and let us know if the problem is resolved.

comment:2 by civileng, 13 years ago

with what fusion version must I test?

comment:3 by madair, 13 years ago

this is committed to trunk so if you can test the trunk from SVN that woud be helpful

in reply to:  3 comment:4 by civileng, 13 years ago

Replying to madair:The trunk SVN version is working perfectly. Also I have tested with the fusion version that come with the mapguide 2.1.0.4283-final. In this case this issue still is present.

this is committed to trunk so if you can test the trunk from SVN that woud be helpful

comment:5 by civileng, 13 years ago

I would like remark that with the trunk fusion version all maps whose projection system is the 900913 (google projection) are not being displayed correctly. In the startup the map shows a AJAX message: Fusion Error: WARNING: Exception occurred in AJAX callback. Message: this.events[eventID] is undefined Location: http://localhost/mapguide/fusion/lib/EventMgr.js (59) Response: {"sessionId":"347a9be8-c5a3-102c-8000-0003ff6c0cf3_en_7F0000010AFC0AFB0AFA","mapId":"Library:\/\/Rwanda\/Maps\/rwGmap.MapDefinition","metersPerUnit":1,"wkt":"PROJCS[\"Popular Visualisation CRS \/ Mercator\",GEOGCS[\"Popular Visualisation CRS\",DATUM[\"Popular_Visualisation_Datum\",SPHEROID[\"Popular Visualisation Sphere\",6378137,0,AUTHORITY[\"EPSG\",\"7059\"]],TOWGS84[0,0,0,0,0,0,0],AUTHORITY[\"EPSG\",\"6055\"]],PRIMEM[\"Greenwich\",0,AUTHORITY[\"EPSG\",\"8901\"]],UNIT[\"degree\",0.01745329251994328,AUTHORITY[\"EPSG\",\"9122\"]],AUTHORITY[\"EPSG\",\"4055\"]],UNIT[\"metre\",1,AUTHORITY[\"EPSG\",\"9001\"]],PROJECTION[\"Mercator_1SP\"],PARAMETER[\"central_meridian\",0],PARAMETER[\"scale_factor\",1],PARAMETER[\"false_easting\",0],PARAMETER[\"false_northing\",0],AUTHORITY[\"EPSG\",\"3785\"],AXIS[\"X\",EAST],AXIS[\"Y\",NORTH]]","epsg":0,"siteVersion":"2.1.0.4283","mapTitle":"rwGmap","mapName":"rwGmap4b1d6fd5354dc","backgroundColor":"#ffffff","extent":[3116945,-334111,3450904,-111325],"layers":[{"uniqueId":"34d7d25e-c5a3-102c-8000-0003ff6c0cf3","layerName":"distSHP","layerTypes":[2], ....

Cheers.

comment:6 by madair, 12 years ago

Resolution: fixed
Status: assignedclosed

from the comments, it appears that the original issue has been solved so closing this ticket.

I suspect the Fusion error mentioned in the above comment has been fixed as there has been some fixes applied for commercial map layers as part of other tickets.

Note: See TracTickets for help on using tickets.