Opened 14 years ago

Closed 14 years ago

#126 closed defect (fixed)

Double Map Name in Custom Tasks

Reported by: cgountanis Owned by: madair
Priority: P2 Milestone: 1.1
Component: MapGuide Version: 1.0.7
Severity: Major Keywords:
Cc: Browser: All
External ID: Operating System: All
state: Approved

Description

To reproduce this you need to creat a task page and in the layout point this task to a custom web page. Notice Default48cac719ef247 is in the string twice. This is an annoyance which casues third party programming issues. Why does it duplicate URL or Query String data when you run a custom task.

Example of QueryString

http://servername/webdirectory/somecode.aspx?LOCALE=en&SESSION=64f05ab8-0000-1000-8000-000423883456_en_7F0000010AF20AF10AF0&MAPNAME=Default48cac719ef247&LOCALE=en&SESSION=64f05ab8-0000-1000-8000-000423883456_en_7F0000010AF20AF10AF0&MAPNAME=Default48cac719ef247

Change History (4)

comment:1 by pagameba, 14 years ago

state: NewAnalysis Requested

A quick inspection of the code doesn't reveal anything particularly obvious that would be causing this. Analysis required.

comment:2 by pagameba, 14 years ago

state: Analysis RequestedApproved

Actually, I spoke too soon - I was looking in Studio for something else and realized that there are two widgets in play here, TaskPane and InvokeURL, and it turns out that both of them are adding the three parameters to the URL. I'm not sure which widget's implementation is better, but "there can only be one"!

Thinking this through a little, InvokeURL can open a page in either the task pane or another frame or a separate window, so it needs to add the parameters. Other widgets like BufferPanel can do the same. I think that the extra parameters should be removed from the code in TaskPane.

Mike, please review this and see if there are any other widgets that can target the taskpane that don't add the parameters and adjust them to add the parameters, then remove that code from TaskPane.

comment:3 by madair, 14 years ago

(In [1591]) re #126: remove default params from TaskPane and add to Help widget; other widgets already add the necessary params; fix error with mapName param for queryLayer

comment:4 by madair, 14 years ago

Resolution: fixed
Status: newclosed

(In [1592]) closes #126: patch applied to trunk

Note: See TracTickets for help on using tickets.