Opened 14 years ago

Closed 13 years ago

#121 closed defect (fixed)

Regression: Selection in an MGE Flexible Web Layout fails if a raster layer is visible and selectable

Reported by: davewilson Owned by: madair
Priority: P1 Milestone: 2.0
Component: MapGuide Version: 1.0.7
Severity: Major Keywords:
Cc: Browser: All
External ID: Operating System: Windows
state: Analysing

Description

Create an MGE map with 2 or 3 layers where one of them is a Raster image. In the map definition by default a layer is marked as selectable. If the user switches to select mode and drags a rectangle so select some features while the raster layer is visible the layout will hang for a minute or so and eventually an AJAX Callback error with a server exception is raised saying "Error: Cannot create any more connections to the Autodesk.Raster FDO provider". This was not an issue with the version included in the 32.2 RTM build of MGE 2009.

A workaround is possible by setting the raster layer to not be selectable in the map.

Change History (5)

comment:1 by madair, 14 years ago

state: NewAnalysing
Status: newassigned

comment:2 by madair, 14 years ago

Milestone: 1.12.0

I am unable to reproduce this error, please provide a package to test with.

Moving this to the 2.0 milestone

comment:3 by davewilson, 14 years ago

I suspect this was a connection pooling problem that has been fixed with the addition of Raster connection pooling in SP1. Although there is the possibility that the error is related to a raster image that uses a connection to a file or folder rather than uploaded. When the map has just the raster layer and the same map is used in overview map in the layout you should get an error when attempting to select by dragging a rectangle. You should previously have some Montana data supplied a while back that should work for this. I don't want to try and upload a large attachment as we had issues with this before.

comment:4 by davewilson, 14 years ago

If I have just a raster image that is based on a connection to a file in a folder and it's the only thing in the map I can generate an "invalid filter" fdo error when attempting to select the raster. If after the error I zoom and select again I get an unclassified exception from the server. I spoke to Tom Fukushima and for now we think fusion should ignore raster layers during it's selection process, even though the map definition might say the layer is selectable. Currently our AJAX Viewer ignores raster layers during selection. The cpu also pins during this sequence which is odd. This doesn't happen with an uploaded image which suggests we probably have a problem with our raster provider.

Something to consider for the future: does WMS support selection on raster requests? MapGuide can't distinguish between a WMS layer and raster layer at this point so even if it did we can't really support it. What about OpenLayers does it support selection on rasters?

comment:5 by madair, 13 years ago

Resolution: fixed
Status: assignedclosed

Still can't reproduce this. Note that rasters are excluded from the selection as part of changeset 1120 (http://trac.osgeo.org/fusion/changeset/1120). Reverting that changeset gives the "FDO Provider Not Registered An exception occurred in FDO component." error so I believe this issue is no longer valid.

Please re-open the ticket with a .mgp package to test with if this is not the case.

Note: See TracTickets for help on using tickets.