Opened 4 years ago

Closed 9 months ago

#935 closed defect (fixed)

Failure stripping PostGIS axis from srid=2000

Reported by: jng Owned by: badreddinekaroui
Priority: major Milestone:
Component: PostgreSQL Provider Version:
Severity: 3 Keywords:
Cc: External ID:

Description (last modified by jng)

After #934, the PostGIS suite has this one last test failure

PostGIS spatial context test is failing for srid=2000 with this WKT:

PROJCS["Anguilla 1957 / British West Indies Grid",GEOGCS["Anguilla 1957",DATUM["Anguilla_1957",SPHEROID["Clarke 1880 (RGS)",6378249.145,293.465,AUTHORITY["EPSG","7012"]],AUTHORITY["EPSG","6600"]],PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]],UNIT["degree",0.0174532925199433,AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4600"]],PROJECTION["Transverse_Mercator"],PARAMETER["latitude_of_origin",0],PARAMETER["central_meridian",-62],PARAMETER["scale_factor",0.9995],PARAMETER["false_easting",400000],PARAMETER["false_northing",0],UNIT["metre",1,AUTHORITY["EPSG","9001"]],AXIS["Easting",EAST],AXIS["Northing",NORTH],AUTHORITY["EPSG","2000"]]

The fixed WKT is malformed at the end (note the lack of comma before the last AUTHORITY element

PROJCS["Anguilla 1957 / British West Indies Grid",GEOGCS["Anguilla 1957",DATUM["Anguilla_1957",SPHEROID["Clarke 1880 (RGS)",6378249.145,293.465,AUTHORITY["EPSG","7012"]],AUTHORITY["EPSG","6600"]],PRIMEM["Greenwich",0,AUTHORITY["EPSG","8901"]],UNIT["degree",0.0174532925199433,AUTHORITY["EPSG","9122"]],AUTHORITY["EPSG","4600"]],PROJECTION["Transverse_Mercator"],PARAMETER["latitude_of_origin",0],PARAMETER["central_meridian",-62],PARAMETER["scale_factor",0.9995],PARAMETER["false_easting",400000],PARAMETER["false_northing",0],UNIT["metre",1,AUTHORITY["EPSG","9001"]]AUTHORITY["EPSG","2000"]]

Change History (3)

comment:1 Changed 4 years ago by jng

Description: modified (diff)

comment:2 Changed 10 months ago by jng

Component: Utilities APIPostgreSQL Provider
Owner: changed from gregboone to badreddinekaroui

comment:3 Changed 9 months ago by jng

Resolution: fixed
Status: newclosed

In 8099:

Fix some test failures in the PostGIS test suite

  • Update expected geometry types some PostGIS master files. The recent support for curve geometries rendered the previous versions incorrect
  • On a similar theme, update LogicalPhysicalHybridBender?.xslt to reflect the updated geometry support list for PostGIS
  • Update SC axes test to verify additional corner cases
    • Fix incorrect WKT re-assembly when stripping out axis defns from the source WKT. It should be re-assembled with a comma. The absence of this comma was the cause of the strange resulting WKT as reported in #935

Fixes #935

Note: See TracTickets for help on using tickets.