Opened 5 years ago

Closed 5 years ago

#914 closed defect (fixed)

Fail to connect to WMS server http://geodienste-hamburg.de/HH_WMS_Statistische_Gebiete?

Reported by: christinebao Owned by: gregboone
Priority: major Milestone: 4.1.0
Component: WMS Provider Version: 4.0.0
Severity: 3 Keywords:
Cc: External ID:

Description

Reported by Autodesk QA:

  1. Connect to http://geodienste-hamburg.de/HH_WMS_Statistische_Gebiete?.
  2. Report error:
Connection Failed.
FDO connection could not be opened.
Unexpected error when accessing the server.
The requested URL returned error: '400 Missing HTTP version in request:'.

Attachments (1)

Fix914.patch (657 bytes) - added by christinebao 5 years ago.
Attach fixing.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 5 years ago by christinebao

Cause:

The defect was caused by a submission in FDO r7180, which caused an unnecessary “&” in request http://geodienste-hamburg.de/HH_WMS_Statistische_Gebiete?version=1.3.0&&service=WMS&REQUEST=GetCapabilities , and the server cannot parse the request so return error.

Fix:

Fix the algorithm of generating url.

Changed 5 years ago by christinebao

Attachment: Fix914.patch added

Attach fixing.

comment:2 Changed 5 years ago by christinebao

Submit to trunk at r7456.
Submit to 4.1 branch at r7457.
Submit to 4.0 branch at r7458.

comment:3 Changed 5 years ago by christinebao

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.