Opened 7 years ago

Closed 7 years ago

#890 closed defect (fixed)

Failed to connect to the https WMS server

Reported by: christinebao Owned by: Christine Bao
Priority: major Milestone: 3.9.0
Component: WMS Provider Version: 3.9.0
Severity: 3 Keywords:
Cc: External ID: DE13923

Description

Reported from Autodesk QA:

connect to https://webgis.dme.qld.gov.au/webgiswms/com.esri.wms.Esrimap/IRTMWMS and meets error. It's a regression defect, 3.8.0 works.

Attachments (1)

Fix890.patch (638 bytes) - added by christinebao 7 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 7 years ago by christinebao

This error was caused by recently open SSL upgrade. libCurl reports error:


CURLE_SSL_CONNECT_ERROR (35)

A problem occurred somewhere in the SSL/TLS handshake. You really want the error buffer and read the message there as it pinpoints the problem slightly more. Could be certificates (file formats, paths, permissions), passwords, and others.

More details: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version


By investigation it means client SSL version is different from server's. To avoid reporting this error, make libCurl ignores version difference by setting options:

curl_easy_setopt(curlHandle, CURLOPT_SSLVERSION, 1);

Reference to http://mikeytag.tumblr.com/post/29612114990/fixing-ssl-handshake-with-php5-and-curl.

Changed 7 years ago by christinebao

Attachment: Fix890.patch added

comment:2 Changed 7 years ago by christinebao

Thanks Greg Boone for reviewing.

Submit to trunk in r7098, 3.9 branch in r7099.

comment:3 Changed 7 years ago by christinebao

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.