Opened 8 years ago

Closed 8 years ago

#827 closed defect (fixed)

Ubuntu 11.10 build fixes (xalan thirdparty)

Reported by: jng Owned by: gregboone
Priority: major Milestone: 3.7.0
Component: Build System Version: 3.7.0
Severity: 3 Keywords:
Cc: External ID:

Description

Attached is a patch to allow the internal xalan library to build under Ubuntu 11.10 with GCC 4.6

Attachments (1)

xalan_ubuntu.patch (5.6 KB) - added by jng 8 years ago.
xalan patches

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by jng

Attachment: xalan_ubuntu.patch added

xalan patches

comment:1 Changed 8 years ago by jng

The problems this patch fixes are basically in 2 categories:

  1. Mutable reference members are not allowed in GCC 4.6 (source). The patch simply removes this keyword
  1. The linker breaks down with 'undefined reference to <some API in xerces>'. This was caused by the linker flags being specified in the wrong order (older GCC versions probably didn't care). The patch re-orders these flags for the linker to properly work

comment:2 Changed 8 years ago by jng

Resolution: fixed
Status: newclosed

Fixed r6438 (Trunk) and r6439 (3.7)

Note: See TracTickets for help on using tickets.