Opened 8 years ago

Closed 8 years ago

#809 closed defect (fixed)

Ambiguous field in FDO query filter in select with joins.

Reported by: StevenXu Owned by: StevenXu
Priority: major Milestone: 3.7.0
Component: SQLite Provider Version: 3.7.0
Severity: 3 Keywords:
Cc: External ID: 1444194.01

Description

An exception was thrown as "Ambiguous field.." while using IN condition in select command with joins.

Change History (1)

comment:1 Changed 8 years ago by StevenXu

Resolution: fixed
Status: newclosed

Fixed it in trunk stream with submission r6357https://trac.osgeo.org/fdo/changeset/6357

This defect was caused by FDO SQLite provider, when users create select with joins and use IN condition as the filter, the SQLite provider failed to translate the FDO class name in IN condition.

This submission fixed this problem and one test case was add in unit tests to verify it.

Note: See TracTickets for help on using tickets.