Ticket #980 (closed defect: wontfix)

Opened 4 years ago

Last modified 3 years ago

topology Regress failures on 9.1 beta - array_lower(topology.topoelementarray, integer) does not exist

Reported by: robe Owned by: strk
Priority: medium Milestone: PostGIS 2.0.0
Component: topology Version: trunk
Keywords: Cc:

Description

strk,

Sorry haven't been regress testing topology since the raster regress issue I am having interrupted this so had to create a special regress line to test topology.

Anyrate I still have to test on 9.0, but I get a lot of failures on 9.1.

Spot checking some -- they all look like same error

psql:load_features.sql:68: ERROR:  function array_lower(topology.topoelementarray, integer) does not exist

So I guess maybe you need to put in an explicit cast to cast topoelementarray to a regular array. Hmm could be a bug in 9.1 though. I don't see why this should be necessary.

I've zipped up my regress log

Attachments

pgis_reg_6256.zip Download (16.9 KB) - added by robe 4 years ago.

Change History

Changed 4 years ago by robe

Changed 4 years ago by strk

Try reporting it upstream, if it's in beta and is a bug it may be fixed before final.

Changed 4 years ago by robe

strk,

Don't bother fixing this. The more I think about it the more I think this is a bug in PostgreSQL 9.1. I was looking at my PostgreSQL 9.1 bea 1 database in pgAdmin for example and topology.topoelementarray doesn't even display under domains nor under types, yet it does in my 9.0 equivalent database. I'll report this to the authorities.

So in short:

SELECT array_upper(ARRAY[ARRAY[1,2], ARRAY[3,4]]::topology.topoelementarray,1);

-- Works fine in 9.0 and 8.4

In PostgreSQL 9.1 it throws a: function array_upper(topology.topoelementarray, integer) does not exist error

Changed 4 years ago by robe

strk,

Just a heads up -- it's not really a bug, but they are thinking about it. See thread:

 http://archives.postgresql.org/pgsql-hackers/2011-05/msg01143.php

Changed 3 years ago by robe

update -- looks like they have a plan to deal with this that will not require us to change anything.  http://archives.postgresql.org/pgsql-hackers/2011-06/msg00191.php

And they plan to release a beta2 on Monday June 13th.  http://archives.postgresql.org/pgsql-hackers/2011-06/msg00189.php

I presume that should have the fix in it. I'll test then and close this out if it works.

Changed 3 years ago by robe

  • status changed from new to closed
  • resolution set to wontfix

Okay Tom Lane seems to have fixed this one in 9.1 beta 2 -- so it's a non-issue now. But got mostly all regression failures for topology. Will put that in as a separate ticket.

Note: See TracTickets for help on using tickets.