Ticket #794 (closed task: fixed)
Rename function ST_ModEdgesSplit to ST_ModEdgeSplit
|Reported by:||robe||Owned by:||strk|
This we discussed in: http://www.postgis.org/pipermail/postgis-devel/2011-January/011541.html
That in current and older versions this function was transcribed wrong and the name is not SQL-MM compliant. But strk felt we should keep it. I personally feel we should just scrap ST_ModEdgesSplit to minimize on confusion (with new users accidentally using the old function name) with a change note in the docs and readme that this function name has changed and can be aliased back to old name if really needed. Perhaps put in a legacy script like we are building for the core postgis stuff I'm dissecting out.
I consider this a new beginning for topology and just want to shed old confusing baggage so we can add really useful baggage.