Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#770 closed defect (fixed)

[topology] AddEdge refuses to add closed edge touching at endpoint

Reported by: strk Owned by: strk
Priority: medium Milestone: PostGIS 2.0.0
Component: topology Version: trunk
Keywords: Cc:

Description

Problem is that ST_Relate returns interior intersection as GEOS takes closed linestrings as having NO boundary.

Not sure this is to be considered a bug in postgis or GEOS

Change History (4)

comment:1 Changed 8 years ago by strk

Milestone: PostGIS 1.5.3PostGIS 2.0.0
Owner: changed from pramsey to strk
Status: newassigned
Version: 1.5.Xtrunk

comment:2 Changed 8 years ago by robe

Component: postgistopology

comment:3 Changed 8 years ago by strk

Resolution: fixed
Status: assignedclosed

Fixed in r6626

comment:4 Changed 8 years ago by strk

for the record, the fact that closed linestrings have no boundary is not a bug, but follows OGC definitions. See #844 for requesting a different interpretation.

Note: See TracTickets for help on using tickets.