Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2784 closed patch (fixed)

configure --with-scfgal=/usr/local/bin won't fail

Reported by: vmo Owned by: robe
Priority: medium Milestone: PostGIS 2.1.4
Component: sfcgal Version: 2.1.x
Keywords: Cc:

Description

If you specify something else that the sfcgal-config script as the --with-sfcgal option value, the configure script won't fail but the build will (undefined symbols)

Attachments (2)

2784.patch (536 bytes) - added by vmo 5 years ago.
2784_2.patch (548 bytes) - added by giohappy 5 years ago.

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by vmo

Attachment: 2784.patch added

comment:1 Changed 5 years ago by robe

Component: postgissfcgal
Owner: changed from pramsey to colivier

comment:2 Changed 5 years ago by robe

Owner: changed from colivier to robe
Type: defectpatch

comment:3 Changed 5 years ago by strk

I saw the problem is use of "test -x" which tests if a file is "executable". Directories are "executable" if they can be browsed, so the test should be changed to test for the file to be "a file" _and_ be "executable".

comment:4 Changed 5 years ago by strk

Oh but the patch is good for me, even better than trusting "test" :) NOTE: the same test is used with gdal-config and geos-config, dunno if they have also the same problem (possibly)

comment:5 Changed 5 years ago by strk

Milestone: PostGIS 2.1.4
Resolution: fixed
Status: newclosed

r12664 in trunk, r12665 in 2.1 branch

comment:6 in reply to:  4 Changed 5 years ago by vmo

NOTE: the same test is used with gdal-config and geos-config, dunno if they have also the same problem (possibly)

No they don't (tested).

comment:7 Changed 5 years ago by giohappy

As I suggested in #2785 wouldn't be better having also test -f?

comment:8 Changed 5 years ago by strk

giohappy patches are always welcome :)

Changed 5 years ago by giohappy

Attachment: 2784_2.patch added

comment:9 Changed 5 years ago by giohappy

I didn't attach a patch because one was already submitted and the ticket is closed. Anyway, here it is.

Note: See TracTickets for help on using tickets.