Opened 5 years ago

Last modified 19 months ago

#2630 new defect

Typo in UpdateGeometrySRID parameter name

Reported by: strk Owned by: robe
Priority: medium Milestone: PostGIS Fund Me
Component: postgis Version: 2.1.x
Keywords: Cc:

Description

The signature is:

UpdateGeometrySRID(
 catalogn_name varchar,
 schema_name varchar,
 table_name varchar,
 column_name varchar,
 new_srid_in integer
)

Changing the name of the first argument would require a DROP function...

Assigning to Regina as she feels it's ok to DROP :P

Change History (5)

comment:1 Changed 5 years ago by strk

BTW, should it be ST_UpdateGeometrySRID ?

comment:2 Changed 5 years ago by robe

Milestone: PostGIS 2.1.2PostGIS 2.2.0

I feel it's okay to drop in a minor release. I'm out to lunch in micro -- it's borderline. In most cases I wouldn't unless it was causing problems like ambiguous name conflict.

no I will not name ST_, cause then I'd have to keep the old name anyway and also do the same with all the other management functions -- http://postgis.net/docs/manual-dev/reference.html#Management_Functions

Massive renamings should only be done in major releases in my opinion where people can expect some non-backward compatibility.

comment:3 Changed 5 years ago by robe

oh and we never do renaming of args in micros -- that's a big no no since some people used named args

comment:4 Changed 4 years ago by robe

Milestone: PostGIS 2.2.0PostGIS Future

comment:5 Changed 19 months ago by robe

Milestone: PostGIS FuturePostGIS Fund Me

Milestone renamed

Note: See TracTickets for help on using tickets.