Opened 6 years ago

Closed 6 years ago

#2441 closed defect (fixed)

TIGER Geocoder uses new features only available in Postgres 9.3

Reported by: kyngchaos Owned by: robe
Priority: medium Milestone: PostGIS 2.1.1
Component: tiger geocoder Version: 2.1.x
Keywords: Cc:

Description

Documentation says geocoder requires at least Postgres 9.1.

The scripts generated uses new options in Postgres 9.3 for CREATE SCHEMA: IF NOT EXISTS

Change History (4)

comment:1 Changed 6 years ago by robe

thanks for the catch. I guess I've been so excited about 9.3 that I forgot about all the rest :).

comment:2 Changed 6 years ago by robe

Fixed for 2.2 at r11849

Need to test a bit more before I backport to 2.1. It also includes upgrading the loader which prior was ignoring.

comment:3 Changed 6 years ago by robe

further revised at r11850 after testing under sh

comment:4 Changed 6 years ago by robe

Resolution: fixed
Status: newclosed

Fixed for 2.1.1 at r11851

Note: See TracTickets for help on using tickets.