Opened 6 years ago

Closed 6 years ago

#2415 closed defect (fixed)

ST_Multi does not support curve geometries

Reported by: strk Owned by: strk
Priority: medium Milestone: PostGIS 2.0.4
Component: postgis Version: 1.5.X
Keywords: Cc:

Description

When passed to ST_Multi, COMPOUNDCURVE and CIRCULARSTRING should become MULTICURVE; CURVEPOLYGON should become MULTISURFACE.

Change History (3)

comment:1 Changed 6 years ago by strk

Owner: changed from pramsey to strk
Status: newassigned

Actually CIRCULARSTRING is already supported, only COMPOUNDCURVE and CURVEPOLYGON are not. The problem is with use of lwtype_is_collection, which considers curVEPOLYGON and COMPOUNDCURVE as collections. Fixing that function isn't something for 2.1.0, but changing ST_Multi to avoid it could get into it, IMHO.

comment:2 Changed 6 years ago by strk

Milestone: PostGIS 2.1.0PostGIS 1.5.9
Version: 2.0.x1.5.X

This bug affects even 1.5...

comment:3 Changed 6 years ago by strk

Milestone: PostGIS 1.5.9PostGIS 2.0.4
Resolution: fixed
Status: assignedclosed

r11754 in trunk (2.2.0), r11755 in 2.1 branch (2.1.0), r11756 in 2.0 branch (2.0.4)

Backporting to 1.5 is more work than worth it

Note: See TracTickets for help on using tickets.