Opened 6 years ago

Closed 6 years ago

#2226 closed defect (wontfix)

[raster]: Regress failure on window 8.4 32-bit

Reported by: robe Owned by: Bborie Park
Priority: high Milestone: PostGIS 2.0.4
Component: raster Version: 2.0.x
Keywords: windows Cc:

Description

I was really hoping I'd never have to look at 8.4 again. Oh well. In packaging 8.4 PostGIS 2.0 for windows, running into a regress issue:

 PostgreSQL 8.4.8, compiled by Visual C++ build 1400, 32-bit
 Postgis 2.0.3 - r11128 - 2013-03-10 21:50:06
   GEOS: 3.3.8-CAPI-1.7.8
   PROJ: Rel. 4.8.0, 6 March 2012
   GDAL: GDAL 1.9.1, released 2012/05/15

Running tests

 check_gdal .. ok 
 check_raster_columns .. ok 
 check_raster_overviews .. ok 
 rt_io .. ok 
 rt_bytea .. ok 
 box3d .. ok 
 rt_addband .. ok 
 rt_band .. ok 
 rt_asgdalraster .. ok 
 rt_astiff .. ok 
 rt_asjpeg .. ok 
 rt_aspng .. ok 
 rt_union .. ok 
 create_rt_properties_test .. ok 
 rt_dimensions .. ok 
 rt_scale .. ok 
 rt_pixelsize .. ok 
 rt_upperleft .. ok 
 rt_rotation .. ok 
 rt_georeference .. ok 
 rt_set_properties .. ok 
 drop_rt_properties_test .. ok 
 create_rt_empty_raster_test .. ok 
 rt_isempty .. ok 
 rt_hasnoband .. ok 
 drop_rt_empty_raster_test .. ok 
 rt_metadata .. ok 
 create_rt_band_properties_test .. ok 
 rt_band_properties .. ok 
 rt_set_band_properties .. ok 
 rt_summarystats .. ok 
 rt_count .. ok 
 rt_histogram .. ok 
 rt_quantile .. ok 
 rt_valuecount .. ok 
 rt_valuepercent .. ok 
 rt_bandmetadata .. ok 
 rt_pixelvalue .. ok 
 drop_rt_band_properties_test .. ok 
 rt_utility .. ok 
 create_rt_mapalgebra_test .. ok 
 rt_mapalgebraexpr .. ok 
 rt_mapalgebrafct .. ok 
 rt_mapalgebraexpr_2raster .. ok 
 rt_mapalgebrafct_2raster .. ok 
 drop_rt_mapalgebra_test .. ok 
 create_rt_mapalgebrafctngb_test .. ok 
 rt_mapalgebrafctngb .. ok 
 rt_mapalgebrafctngb_userfunc .. ok 
 drop_rt_mapalgebrafctngb_test .. ok 
 rt_reclass .. ok 
 rt_resample .. failed (diff expected obtained: /tmp/pgis_reg/test_52_diff)
 rt_asraster .. failed (diff expected obtained: /tmp/pgis_reg/test_53_diff)
 rt_intersection .. ok 
 rt_clip .. ok 
 create_rt_gist_test .. ok 
 rt_above .. ok 
 rt_below .. ok 
 rt_contained .. ok 
 rt_contain .. ok 
 rt_left .. ok 
 rt_overabove .. ok 
 rt_overbelow .. ok 
 rt_overlap .. ok 
 rt_overleft .. ok 
 rt_overright .. ok 
 rt_right .. ok 
 rt_same .. ok 
 drop_rt_gist_test .. ok 
 rt_spatial_relationship .. ok 
 rt_intersects .. ok 
 rt_samealignment .. ok 
 bug_test_car5 .. ok 
 tickets .. ok 
 loader/Basic ...... ok 
 loader/BasicCopy ...... ok 
 loader/Tiled10x10 ..... ok 
 loader/Tiled10x10Copy ..... ok 
 uninstall ... ok (3699)

It's possible this affects all 8.4's since neigther winnie nor debbie test against PostgreSQL 8.4.

Regress failures attached. I'm going to upgrade the gdal version to 1.9.2 to see if that fixes.

Attachments (1)

pgis_reg_pg84_windows_203.zip (3.4 KB) - added by robe 6 years ago.

Download all attachments as: .zip

Change History (11)

Changed 6 years ago by robe

comment:1 Changed 6 years ago by robe

nope fails with 9.2. I vaguely remember having this issue when I had my proj env setting snot set right. Thought they seem to be.

comment:2 Changed 6 years ago by robe

I meant gdal 1.9.2

comment:3 Changed 6 years ago by Bborie Park

I think there is a Windows issue. On Linux 64 with PostgreSQL 8.4, GDAL 1.9.2 and PostGIS 2.0-svn, I have no regression issues.

comment:4 Changed 6 years ago by robe

Weird. My others 9.0-9.2 (both 32-bit and 64-bit) regressed cleanly.

Which microversion of 8.4 are you running?

comment:5 Changed 6 years ago by robe

Keywords: windows added

comment:6 Changed 6 years ago by Bborie Park

I'm running PostgreSQL 8.4.14.

comment:7 Changed 6 years ago by robe

okay . I'll try upgrading and see if that fixes my issue.

comment:8 Changed 6 years ago by robe

unfortunately it didn't, but I don't think too many folks are using 8.4 on windows anymore and if they are they are probably too shy to upgrade their PostGIS to 2.0. Even ArcGIS 10 seems to work happily with my PostGIS 2.1.0 install.

comment:9 Changed 6 years ago by Bborie Park

Checking the changelog for 2.0, nothing has changed between 2.0.2 and 2.0.3 and that regress file has been the same from when branch 2.0 was created. Based upon the regress output, it looks like the transformation between SRSes is not taking place. How was GDAL built?

comment:10 Changed 6 years ago by robe

Resolution: wontfix
Status: newclosed

I honestly don't care about 8.4 to even bother checking if there is an issue. don't know any windows user that still uses it with 2.0.

Note: See TracTickets for help on using tickets.