Opened 7 years ago

Closed 7 years ago

#2125 closed defect (fixed)

[raster] cunit raster tests do not build?

Reported by: pramsey Owned by: Bborie Park
Priority: medium Milestone: PostGIS 2.1.0
Component: postgis Version: trunk
Keywords: mac Cc:

Description

ld: duplicate symbol _cu_error_msg in cu_raster_basics.o and cu_pixtype.o
collect2: ld returned 1 exit status
make[3]: *** [cu_tester] Error 1
make[2]: *** [core-check] Error 2
make[1]: *** [check] Error 2
make: *** [check] Error 1

Change History (3)

comment:1 Changed 7 years ago by Bborie Park

Status: newassigned
Summary: cunit raster tests do not build?[raster] cunit raster tests do not build?

Confirmed on 10.6. Will have to do some poking...

comment:2 Changed 7 years ago by robe

Keywords: mac added

I presume this is just a Mac issue? I have no problems with the Cunit tests on windows Both winnie and debbie are as happy as clams with the new cunit tests :)

comment:3 Changed 7 years ago by Bborie Park

Resolution: fixed
Status: assignedclosed

robe, yes. It looks like I had excessive CFLAGS (PICFLAGS specifically) that changed how gcc compiled in OSX. Just needed to remove it.

Fixed in r10779. Works on OSX 10.6 and Linux 64-bit.

Note: See TracTickets for help on using tickets.